Support » Plugin: Lightweight Widget Area Plugin - Content Aware Sidebars » Cannot skip share infos with fremius – no access to settings

  • Resolved wpblogwriter

    (@wpblogwriter)


    Hi,

    Clicking on “Skip” just keeps me on the same page. I cannot access any of the settings…

    Webserver Nginx, PHP 7.x (tried 7.0, 7.1, 7.2, 7.3).

    One error apperaring in logs after I de and reactived the plugin:

    [error] 13917#13917: *21839 open() “/var/www/wp-content/plugins/content-aware-sidebars/lib/freemius/assets/css/admin/plugin-upgrade-notice.css” failed (2: No such file or directory), client: 1.1.1.1, server: website.tld, request: “GET /wp-content/plugins/content-aware-sidebars/lib/freemius/assets/css/admin/plugin-upgrade-notice.css?ver=4.9.9 HTTP/1.0”, host: “www.website.tld”, referrer: “https://www.website.tld/wp-admin/plugins.php?activate=true&plugin_status=all&paged=1&s=”

    I have also re-dowbnloaded the 3.8 version from ths repo and replaced with the version I udpated a couple days ago.
    Now I have this error showing up:

    2019/02/15 11:01:07 [error] 31782#31782: *454 FastCGI sent in stderr: “PHP message: PHP Warning: require_once(/var/www/wp-content/plugins/content-aware-sidebars/lib/freemius/includes/sdk/Exceptions/Exception.php): failed to open stream: No such file or directory in /var/www/wp-content/plugins/content-aware-sidebars/lib/freemius/require.php on line 48PHP message: PHP Fatal error: require_once(): Failed opening required ‘/var/www/wp-content/plugins/content-aware-sidebars/lib/freemius/includes/sdk/Exceptions/Exception.php’ (include_path=’.:/usr/share/php’) in /var/www/wp-content/plugins/content-aware-sidebars/lib/freemius/require.php on line 48” while reading response header from upstream, client: 1.1.1.1, server: website.tld, request: “POST /wp-admin/admin-ajax.php?_fs_blog_admin=true HTTP/1.0”, upstream: “fastcgi://unix:/var/lib/php7.2-fpm/web930.sock:”, host: “www.website.tld”, referrer: “https://www.website.tld/wp-admin/admin.php?fs_action=content-aware-sidebars_skip_activation&page=wpcas&_wpnonce=c8c0a50ece”

    • This topic was modified 1 year, 9 months ago by wpblogwriter.
    • This topic was modified 1 year, 9 months ago by wpblogwriter.
Viewing 6 replies - 1 through 6 (of 6 total)
  • Yes, the same here. Can’t skip. I noticed it only today.

    It seems I can add widgets to existing sidebars, but I cannot create any new sidebar.
    It says: “Sorry, you are not allowed to access this page.”

    Plugin Author Joachim Jensen

    (@intoxstudio)

    Thank you for reporting this and for the stacktraces, very helpful!

    Not being able to Skip is definitely a problem and I will look into it asap. If you opt-in, you can always opt-out from the Plugins screen.

    @mx75

    Do you mean that once you opt-in, you do not have permission to create sidebars? Something similar was reported here, though that was before version 3.8:

    https://wordpress.org/support/topic/add-new-sidebar-sorry-you-are-not-allowed-to-access-this-page/

    Can you post the problem in that thread, along with your WP version, and if you are using any role/capability manager plugin?

    Thanks @joachim. The link you provided solved my issue as well. I had to accept that thing first before plugin “truly” activated. Now I have permissions to create sidebars.

    Plugin Author Joachim Jensen

    (@intoxstudio)

    I tried to install version 3.8 on a clean WordPress 5.1 install and could unfortunately not reproduce the issue. Clicking “skip” worked without any problems.

    I suspect that the problem was caused by an incompatibility with another plugin, but it is hard to say. I strongly recommend that you upgrade to version 3.8.1.

    If there is still a problem after updating, please let me know!

    Never mind. Problem solved.

    • This reply was modified 1 year, 8 months ago by .
    • This reply was modified 1 year, 8 months ago by .

    @joachim Everyone solved this by accepting it. But I have a worse problem I can’t do either of them. freemius.com is blocked in my country (Turkey) when I use vpn it gives another error:
    ( ! ) Fatal error: Uncaught Error: Call to undefined method stdClass::has_trial() in C:\wamp64\www\megatekas\wp-content\plugins\content-aware-sidebars\lib\freemius\includes\managers\class-fs-plan-manager.php on line 155
    ( ! ) Error: Call to undefined method stdClass::has_trial() in C:\wamp64\www\megatekas\wp-content\plugins\content-aware-sidebars\lib\freemius\includes\managers\class-fs-plan-manager.php on line 155
    Call Stack
    # Time Memory Function Location
    1 0.0000 412472 {main}( ) …\admin.php:0
    2 0.4980 14125704 require( ‘C:\wamp64\www\megatekas\wp-admin\menu.php’ ) …\admin.php:152
    3 0.5090 14175368 require_once( ‘C:\wamp64\www\megatekas\wp-admin\includes\menu.php’ ) …\menu.php:308
    4 0.5130 14178016 do_action( ) …\menu.php:154
    5 0.5130 14178392 WP_Hook->do_action( ) …\plugin.php:465
    6 0.5130 14178392 WP_Hook->apply_filters( ) …\class-wp-hook.php:310
    7 0.5250 14303480 Freemius->_prepare_admin_menu( ) …\class-wp-hook.php:286
    8 0.5250 14303560 Freemius->add_menu_action( ) …\class-freemius.php:15153
    9 0.5250 14303560 Freemius->override_plugin_menu_with_activation( ) …\class-freemius.php:15173
    10 0.5250 14302856 Freemius->_install_with_new_user( ) …\class-freemius.php:15300
    11 0.5250 14302856 Freemius->install_with_new_user( ) …\class-freemius.php:14485
    12 24.5554 14340504 Freemius->setup_account( ) …\class-freemius.php:14596
    13 24.5554 14340880 Freemius->setup_network_account( ) …\class-freemius.php:14218
    14 24.5554 14340880 Freemius->_sync_plans( ) …\class-freemius.php:14248
    15 36.5591 14351264 Freemius->do_action( ) …\class-freemius.php:9944
    16 36.5591 14351720 do_action( ) …\class-freemius.php:16064
    17 36.5591 14352096 WP_Hook->do_action( ) …\plugin.php:465
    18 36.5591 14352096 WP_Hook->apply_filters( ) …\class-wp-hook.php:310
    19 36.5591 14353112 Freemius->_check_for_trial_plans( ) …\class-wp-hook.php:286
    20 36.5591 14353528 FS_Plan_Manager->has_trial_plan( ) …\class-freemius.php:19491

    HELP!!

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Cannot skip share infos with fremius – no access to settings’ is closed to new replies.