WordPress.org

Forums

Google Forms
[resolved] Cannot show WP GF settings - error 500 (23 posts)

  1. majo_wordpress
    Member
    Posted 2 years ago #

    I cannot show settings page of this plugin after installation. I get 500 internal error page from my webhosting provider. I try to disable all other plugins, but problem still persists.

    Thanks for your help.

    Martin

    http://wordpress.org/extend/plugins/wpgform/

  2. Mike Walsh
    Member
    Plugin Author

    Posted 2 years ago #

    Can you try temporarily switching to one of the default WordPress themes (TwentyTen, TwentyEleven, or TwentyTwelve) and let me know if the problem persists?

    Is there anything unusual about your server environment? Do you know what version of PHP you are running?

    I need some additional information in order help you out.

  3. majo_wordpress
    Member
    Posted 2 years ago #

    I switch to Twenty Eleven theme, problem persists. I have PHP Version 5.2.17.

  4. Mike Walsh
    Member
    Plugin Author

    Posted 2 years ago #

    I am also running PHP 5.2.17 on my web site. A 500 Error means the web server has failed which usually means some sort of internal PHP error. Do you know what platform your site is running on? I am running under Linux with Apache with MySQL 5.0 and PHP 5.2.17.

    If you want me give me access to your Dashboard I would be happy to take a look. I am not sure what else to suggest at this point. There isn't any unusual PHP in the plugin that I am aware of.

  5. majo_wordpress
    Member
    Posted 2 years ago #

    OK, I can give you access to my WP Dashboard. But I have WordPress in Czech Language. I can also send you phpinfo output, if you want.

  6. Mike Walsh
    Member
    Plugin Author

    Posted 2 years ago #

    I wonder if we're running into a language support issue. Any chance you can switch your blog to English and see if the problem persists?

  7. majo_wordpress
    Member
    Posted 2 years ago #

    I changed 'WPLANG' in wp-config.php to correct English string ("define 'WPLANG', 'cs_CZ'" to "define 'WPLANG', 'en_US'"). My WordPress site is completely in English. I this case problem also still persists.

  8. Mike Walsh
    Member
    Plugin Author

    Posted 2 years ago #

    Ok - let's try this (and if you can leave English on when you do it that would be helpful to me):

    In your wp-config.php add the following:

    define('WP_DEBUG', true); // or false
    if (WP_DEBUG) {
        define('WP_DEBUG_LOG', true);
        ini_set('display_errors', 'on');
        error_reporting(E_STRICT | E_ALL);
        define('SAVEQUERIES', true);
        define('SCRIPT_DEBUG', true);
        error_log('Debug On!') ;
    }

    The WP_DEBUG_LOG setting will cause all PHP errors to be logged to a file called "debug.log" in your wp-content directory. Hopefully by doing this we'll see some sort of PHP error when it fails.

    You can ignore the SAVEQUERIES and SCRIPT_DEBUG settings if you want, that fragment is from my development area.

  9. majo_wordpress
    Member
    Posted 2 years ago #

    I added your code to wp-config. I have WordPress still in English. This is part of my actual wp-config:

    /**
     * For developers: WordPress debugging mode.
     *
     * Change this to true to enable the display of notices during development.
     * It is strongly recommended that plugin and theme developers use WP_DEBUG
     * in their development environments.
     */
    define('WP_DEBUG', true); // or false
    if (WP_DEBUG) {
        define('WP_DEBUG_LOG', true);
        ini_set('display_errors', 'on');
        error_reporting(E_STRICT | E_ALL);
        define('SAVEQUERIES', true);
        define('SCRIPT_DEBUG', true);
        error_log('Debug On!') ;
    } 
    
    /* That's all, stop editing! Happy blogging. */

    I replicate error but the debug.log file is not created in the wp-content directory. What is wrong?

  10. Mike Walsh
    Member
    Plugin Author

    Posted 2 years ago #

    There is nothing there at all? That is odd. Can you disable WordPress Google Form and see if the file gets created? Information on WP_DEBUG_LOG can be found here.

    You can also try this code fragment from the WordPress Codex instead of the one I provided:

    // Enable WP_DEBUG mode
    define('WP_DEBUG', true);
    
    // Enable Debug logging to the /wp-content/debug.log file
    define('WP_DEBUG_LOG', true);
    
    // Disable display of errors and warnings
    define('WP_DEBUG_DISPLAY', false);
    @ini_set('display_errors',0);
    
    // Use dev versions of core JS and CSS files (only needed if you are modifying these core files)
    define('SCRIPT_DEBUG', true);

    Let me know how you make out.

  11. Hanklin
    Member
    Posted 2 years ago #

    Hey guys

    I am having a similar issue. After installing plugins I got the 505 internal server. I have to rename my web.config to view my site.

    It seemed like it was going to be okay until i go into settings and go into permalinks. As soon as I exit, 505 error.

    Even if I go to reading in settings and change main page from static to post or vise versa, 505 error.

    Also when I click on a post from my main page,it says not found and takes me to another website,which is my primary domain.

    Any help would be greatly appreciated

  12. majo_wordpress
    Member
    Posted 2 years ago #

    Mike, if you want, i can prepare a special subdomain for you on my webhosting with new instalation of English WordPress and of course with FTP access. I think that it will be the best to determine the cause of problem with 505 error.

    Is it possible send you PM about access information?

  13. Mike Walsh
    Member
    Plugin Author

    Posted 2 years ago #

    Yes - you can reach me at mpwalsh8 at gmail dot com.

  14. majo_wordpress
    Member
    Posted 2 years ago #

    Ok, I just send it to your email.

  15. Mike Walsh
    Member
    Plugin Author

    Posted 2 years ago #

    I have just posted a new beta release which should fix this issue. It turns out that preg_match_all(), a built-in PHP function, was crashing on the server. This beta update resolves the problem by retrieving and parsing the remote content using the WordPress Plugins API.

  16. Mike Walsh
    Member
    Plugin Author

    Posted 2 years ago #

    @Hanklin - your issues doesn't sound like the same problem @majo_wordpress was running into. Are you still having the issue?

  17. Hanklin
    Member
    Posted 2 years ago #

    Yes i am. After Installing that wordpress security,i think that is the correct name of it, I get the 505 when i exit out of permalink orI change a static front page and have a post front page.

    Also when I click on my post link it takes me to another site of mine , which is my primary domain.

    Sounds crazy. Any help is appreciated

  18. Mike Walsh
    Member
    Plugin Author

    Posted 2 years ago #

    What your describing sounds like a permalink issue. If you disable WordPress Google Form does everything work correctly? If you disable all other plugins besides WordPress Google Form does it still fail?

  19. Hanklin
    Member
    Posted 2 years ago #

    Im not sure If im following you, but I have uninstalled wordpress, then Installed it again and I have the same Issue.

    I have disabled those plugins

  20. Mike Walsh
    Member
    Plugin Author

    Posted 2 years ago #

    You're going to have to give me some more information in order for me to help you. There should be no need to uninstall and re-install WordPress.

    1. How many plugins do you have installed?
    2. What are the names of the other plugins you have installed?
    3. Have you deactivated all plugins besides WordPress Google Form and if so, does the problem persist?
    4. If it does, can you try switching to one of the standard WordPress default themes (e.g. TwentyTen, TwentyEleven, or TwentyTwevle)?
    5. What version of WordPress are you running?
    6. What version of WordPress Google Form are you running?
    7. What version of PHP is your server running?
    8. Is your server Linux/Apache, Windows/IIS, or something else?
    9. Can you provide me temporary access to your site?
  21. Hanklin
    Member
    Posted 2 years ago #

    Heading to a meeting. When I get home i will send you this information. I will not be at a computer until about 9:30.

    When ever you get back to me Is appreciated

    Thank you

  22. Hanklin
    Member
    Posted 2 years ago #

    These two show up in wordpress admin panel as active

    1) AlphaOmega Captcha & Anti-Spam Filter
    Settings | Please Donate | Deactivate | Edit

    2) All in One SEO Pack
    Deactivate | Edit

    These show up in FTP manager
    plugins
    akismet
    jetpack
    alphaomega-captcha-anti-spam
    all-in-one-seo-pac

    I dont see anything called wordpress google. Im green to this sorry

    I Deactvated these plugings and its the same 505.

    I will try TwentyTen, TwentyEleven, or TwentyTwevle
    I am running 3.5.1
    Im using windows
    Not sure were wordpress google is or version of PHP

    Thank you for all your help. let me know if this info helps

  23. Mike Walsh
    Member
    Plugin Author

    Posted 2 years ago #

    I am sorry but if you are not using my WordPress Google Form plugin, then you are in the wrong area of the support forum to resolve the problem you're having.

    My guess is that your problem is from one of the two active plugins (All in One SEO or AlphaOmega Captcha & Anti-Spam). I would try disabling them (deactivate) and see if you still have the same problem.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Google Forms
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic