Support » Plugin: Site Kit by Google » Cannot set-up my site

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Support James Osborne

    (@jamesosborne)

    @chevindu Thanks for the info and context, very useful. Have you tried to install the plugin via a browser incognito window? Sometimes browser caching may interfere. If that fails you also try connecting with some of your plugins temporarily deactivated, or if you have ModSecurity setup on your web host temporarily disable if possible during setup.

    @jamesosborne thanks for the suggestions.

    I tried it with a private browser window, but the result was the same. The URL shown in the browser is:

    https://heavenz.lk/?oauth2callback=1&authuser=0&code=4%2FswH56-dC7NTs72AX4Iy9bp7EFNlCPWo7ZevQ8s_y2NHk03AzHxowtEd2VBOE2FmsQ03-vGCKUq-cTsyvK9gZAKg&prompt=consent&scope=email%20profile%20openid%20https%3A%2F%2Fwww.googleapis.com%2Fauth%2Fuserinfo.profile%20https%3A%2F%2Fwww.googleapis.com%2Fauth%2Fuserinfo.email%20https%3A%2F%2Fwww.googleapis.com%2Fauth%2Fwebmasters%20https%3A%2F%2Fwww.googleapis.com%2Fauth%2Fsiteverification&session_state=b0d1c14c8a171eac417643c6906290c0c9e91d23..80f4

    Then I tried deactivating my first 3 plugins and setting up. After allowing the permissions, I was directed to my blog again. But this time, it throws a “Server taking too long to respond” error. I cannot access my site back-end or front-end, and the FTP connection to my server is not working either.

    So I think I fell into a worse position than I was in. I’d really appreciate if you can let me know if you got any clue why this happened, while I try to calm down the client. Thanks!

    Plugin Support James Osborne

    (@jamesosborne)

    @chevindu Do you have the ModSecurity enabled at host level? If so you can temporarily deactivate during setup, or ask your web host. It’s sometimes possible to disable using your .htaccess file also, but check with your web host.

    @jamesosborne I will, thanks. But I think I got a more urgent issue here to handle. I will check as soon as I could access my cPanel again.

    Plugin Support Renee Johnson

    (@reneesoffice)

    @chevindu I am checking if you had further questions about the issue or if it has been resolved? If so, send a reply to let me know and I will update your support topic accordingly.

    chevindu

    (@chevindu)

    Thanks for your inputs.

    I asked my host whether ModSecurity is activated and the response was as follows.

    Yes, it is enabled and unfortunately, it cannot be changed since WordPress users are always opening backdoors to the server. As an example, please find the mod security violations below;

    2019-11-02 08:48:36 heavenz.lk 112.134.66.53 ERROR 403
    Request:
    GET /?customize_changeset_uuid=8c191f31-142a-4881-bea1-a378808f2e90&customize_theme=throne&customize_messenger_channel=preview-0&customize_autosaved=on
    Action Description:
    Access denied with code 403 (phase 4).
    Justification:
    Matched phrase "b> on line " at RESPONSE_BODY.
    2019-11-02 08:40:28 heavenz.lk 3.83.104.187 CRITICAL 403
    Request:
    GET /.git/HEAD
    Action Description:
    Access denied with code 403 (phase 1).
    Justification:
    Matched phrase "/.git/" at REQUEST_URI.
    2019-11-02 06:49:58 heavenz.lk 52.55.244.91 ERROR 404
    Request:
    GET /
    Action Description:
    Access denied with code 403 (phase 4).
    Justification:
    Pattern match "(?:<(?:TITLE>Index of.?>Index of. ?Index of|>\[To Parent Directory\]<\/[Aa]>>)" at RESPONSE_BODY.

    Therefore I had to deactivate the plugin. Sorry for the delay, and I hope this helps. Thanks!

    • This reply was modified 3 months ago by chevindu. Reason: formatting the code snippet
    • This reply was modified 3 months ago by chevindu. Reason: formatting the code snippet
    • This reply was modified 3 months ago by Jan Dembowski.
    Plugin Support James Osborne

    (@jamesosborne)

    @chevindu Thanks for the update. There is an open GitHub issue on the plugins repository which you can keep track of here.

    chevindu

    (@chevindu)

    Thanks for the link, I will follow it up. Good luck!

    Plugin Support James Osborne

    (@jamesosborne)

    Hi @chevindu. Just following up with you as we have made some significant upgrades to the plugin as of version 1.1.2. There is now no dependence on the REST API, which I believe may have been contributing to your setup issue.

    Can you check and see if Site Kit works for you after upgrading? As an early Site Kit user we would love to hear your feedback, please let me know how you get on after attempting setup with the latest version.

Viewing 9 replies - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.