Support » Plugin: SiteOrigin Widgets Bundle » Cannot Set Margins On Widgets After Upgrading to 1.17.4

  • Resolved cpcusteve

    (@cpcusteve)


    Since upgrading to 1.17.4, when attempting to change the layout of widgets in a row using Widget Styles->Layout, setting the Margins and/or Paddings settings has no effect. This applies to all the Siteorigin widgets that I’ve tried to date, examples being the Editor and Button widgets and is the same whether building an entire page using the Pagebuilder, or a Pagebuilder block within Gutenberg.

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author Andrew Misplon

    (@misplon)

    Hi Steve

    Thanks for reaching out.

    Please, send a link to a page concerned and let us know which widget to check. So far, I haven’t been able to replicate locally.

    Thread Starter cpcusteve

    (@cpcusteve)

    Hi Andrew

    Thanks for getting back to me so promptly.

    If you look at this page https://website.cpcu.co.uk/test-page/ as an example, you will see 2 Editor widgets and a Button widget. If I edit the second Editor widget, go to the Attributes and change the margins to, say 1000 px, the editor shows the new margins as expected. But when I save and view the page, nothing has changed.

    Also, with the Button widget, I’ve found that if I change the button title, again, the editor shows the changed text, but if I save and view the page, the text doesn’t show.

    Let me know if I can help further.

    Thread Starter cpcusteve

    (@cpcusteve)

    Further to this, I think I’ve tracked down the problem. It appears that the plugin, Google Analytics for WordPress by MonsterInsights, was recently updated to 7.12.0. There looks like some incompatibility between this and the SiteOrigin Widgets Bundle or Page Builder (not sure which). Rolling back the Analytics version to 7.11.0 appears to have fixed it. Seems to mess with the Widget bundle interface in some way.

    Phew! Glad to get that sorted.

    Plugin Author Andrew Misplon

    (@misplon)

    Super, thanks for investigating the issue and locating the conflict. I’ll take a look tomorrow when I’m back online and log an issue on our end. I’ll keep you updated as we progress and let you know if there is anything we can do to avoid the conflict. Thanks again!

    Thread Starter cpcusteve

    (@cpcusteve)

    Hi Andrew

    If it helps, have opened a thread on the Google Analytics support page, see https://wordpress.org/support/topic/7-12-0-causes-siteorigin-pagebuilder-and-widget-bundle-to-malfunction/#post-13224300 which shows that other people are having problems occurring with other plugins, not just SiteOrigin plugins. Seems that it’s throwing a Javascript error which I’ve managed to reproduce on my test page as well.

    Plugin Author Andrew Misplon

    (@misplon)

    Super, thanks for spending time on this and for keeping us up to date. It sounds like a fix will be out next week and the Headline Analyzer can be disabled for now as a hotfix.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Cannot Set Margins On Widgets After Upgrading to 1.17.4’ is closed to new replies.