Support » Fixing WordPress » Cannot select text in text widget

  • Hello. Previously I was able to select text for deleting or copying within the text widget. I am just putting together a new blog, here and when I am in the admin, I can insert text ok but I can only delete it one character at a time. Makes changes slow.

    Is this expected behavior?



Viewing 15 replies - 1 through 15 (of 20 total)
  • computerfriend


    I find it hard to believe that WordPress programmers would leave a bug so obvious as the Text Widget Text Selection Bug in WordPress 2.3.1. No, I haven’t been able to select text inside a text widget by dragging across it using Internet Explorer 6 or 7 on a PC which is what the majority of the world uses, regardless of what prejudices some computer geeks have.

    I’m very sorry I upgraded to this latest version of WordPress because I can’t go back now. This bug along with the “Login screen Error” bug has caused me to begin looking at switching to Joomla 1.5 because my clients are noticing these bugs and worrying about them. I taught my clients to log in and publish, now I have to apologize to them that things don’t work right after the latest upgrade.

    It seems to me that before a release of WordPress is announced as stable, bugs like these need to be caught and fixed because they are so dad burned obvious.
    If anyone out there is listening, please fix the text widget text selection bug and the login logout error message bug soon.

    With all that being said, I have to appreciate all the wonderful things that WordPress authors have done right. It is a fabulous program and has enabled hundreds of thousands of people to self publish. What a great contribution to all of us. Thank you, programmers, authors, contributors!!

    Moderator Samuel Wood (Otto)

    (@otto42) Admin

    I find it hard to believe that WordPress programmers would leave a bug so obvious as the Text Widget Text Selection Bug in WordPress 2.3.1.

    No such bug exists. I’m able to select text in the text widgets just fine with 2.3.1.

    login logout error message bug

    Again, no such bug exists. I do not see what you’re describing on any 2.3.1 site.

    bugs like these need to be caught and fixed because they are so dad burned obvious.

    Don’t instantly assume that a problem with your site is a universal problem across all sites. Most likely, you’re missing some javascript files on your site or you have some kind of browser caching problem or something else.

    Whatever the problem is, we’re willing to help you solve it, but we cannot help you if you’re just going to shout “fix it! fix it!” and not actually attempt to fix your site in particular. Because that’s where the bug is: Your site. It’s not on ours.

    Note: if there is a bug, it’s a bug that doesn’t show up on the majority of WordPress installations. So when you think it’s “dad burned obvious”, you’re wrong. It’s not obvious, because we don’t see it on our sites. If we did, we’d fix it. Obviously.

    Well, I’m not convinced that these bugs don’t exist. They exist in a number of different installations and have been commented upon by quite a few people here and elsewhere. If these bugs don’t exist in the programmers’ particular versions of PHP and MySql, then they don’t have the bug. However, quite a large number of sites and people do have the Widgets issues and the Cookies/Login/Logout error messages. So don’t assume just because you regard yourself as a holier-than-thou high fallutin programmer that these bugs don’t exist. They do. There are people who have run into both of these bugs on http://WWW.WORDPRESS.COM. So go figure that out and then come back and criticize my criticism. There are a lot of variables involved in programming and in the end-user experience,and what works for some or even for many does not work for all or a minority that could be as large as 49%. I don’t need to be right. I just need for WordPress to be stable and not offer any big surprises when upgrades are made from previously stable versions. We’ve been using WordPress for 2 years now on about 20 different installations, and we know enough about what we are talking about here to make statements.
    Instead of telling me that I’m wrong, why don’t you spend your time finding out what might be causing a number of people here to have broken sites that weren’t broken before the 2.3.1 iteration made its appearance.

    Just a small add, I hadn’t need to try it yet, but indeed, in a text widget I can only put my cursor somewhere and delete letter by letter. There’s no dragging, double-click on a word, etc.
    I don’t have problems with login in, even though I use several widgets.

    I had the trouble in IE7. In FF there is no problem so that is what I use for editing text widgets.

    You’re right, no problems with Firefox, but Browzar (1.3) has the same problem. Strange.

    This is indeed a bug when using IE7.

    I have somewhat of a similiar problem with my text widget. It will let me paste my rss code into it and when I exit and save, it does not stay in the text box. I am not able to put feedburner icons on my wp blog and it is really frustrating me.

    When I go back into the text widget, there is nothing there.

    Could the browser I am using have something to do with this?

    i have the same problem, i suppose it’s just being ignored? regardless, it’s a pain in the neck.

    Moderator Samuel Wood (Otto)

    (@otto42) Admin

    I can reproduce this problem with IE6 as well. Seems to be an IE bug of some kind.

    As a workaround for now, use Firefox. Click the BrowseHappy link at the bottom of all WordPress admin screens to get a copy of a working browser.

    And note that in the future, if you’re going to claim that a bug exists, you need to also explain under what conditions it exists. If you’re using IE, then we don’t know that unless you tell us. It’s highly unlikely that any serious web developers use IE, for example, so it’s not something we regularly test with. Same goes for any non-standard browsers like Safari or Opera or what have you.

    Dear Otto42, I cannot beleave you wrote this in earnest:

    As a workaround for now, use Firefox.

    Is this official WordPress policy? We cannot fix it, so use another browser as some 25% of you do anyway? Click the BrowseHappy link? Is it up to you to tell people which browser to use? This is ridiculous. As is the statement, you are not even testing wordpress for use with the browser the majority of your customers use.

    Dear Otto42, isn’t it time to apologize? Instead you keep insulting people after not paying attention. User computerfrien said inthe secont post up there “using Internet Explorer 6 or 7 on a PC”. The problem still is there.

    Hi, its me again.

    I looked into the topic a little deeper. Theres a bug with jQuery Dragging. The Options Dialog of widget is draggable (reasons for that are not obvious to me). Since IE is highlighting text of layers under a dragged div, jQuery intentionally disables highlighting while dragging divs. Well, I looked into it just a little, deeper, so I dont know yet how to really fix this keeping the draggability of the dialog, but for a workaround I came up with the idea of just disabling the (unneeded?) draggability:

    in wp-admin/widgets.php commented out the line
    jQuery('#<?php echo $widget['id']; ?>control').Draggable({handle: '.controlhandle', zIndex: 1000});

    Is there anyone who could confirm wether this works or not on perhaps improve on this?


    You are not alone. I am having the same exact problem using IE7. Although, I have been using IE7 for quite some time this problem didn’t arise until I installed version 2.3.1.

    I just upgraded to 2.3.2 and unfortunately the problem still exists. It is extremely frustrating!!! And I don’t want to have to keep switching between IE and Firefox when I have to make updates to my widgets, that’s just crazy.

    Hopefully they will be able to come up with a way to fix this problem ASAP!

    Seems to be more than one or two confused users here. I am using WP 2.3.2, IE 7 with the latest patches. I thought for awhile I was doing something wrong. I had two text widgets in use, tried to add a third with no joy. Then tried to change an exisiting on, again, no success. I found this thread, read down and also found Otto’s comments very odd at the least. Yes it can be done in Firefox, but… when I travel, which is often I go with a laptop from work. I cannot put FF on it due to IT restrictions…. so I am stuck. This is a real problem. It is not limited to backspacing and/or cut and paste. I cannot create a new widget or alter an existing one.
    Hopefully WP support will take notice before long? Is there any other recourse for getting this done?

    Moderator Samuel Wood (Otto)

    (@otto42) Admin

    This is the support forum only. This is not the place to report WordPress bugs.

    Have you reported the bug through trac?

    The developers of WordPress rarely read these forums. They read the mailing lists and trac. Those are the places to go if you consider something to be a bug.

    Also, the active development versions of WordPress have an entirely new interface for widgets, so you should consider trying that before reporting this as a bug. It may not be a bug in the active development version.

    Also, nullbarriere, I said “as a workaround for now” and I stand by that. Speaking about “official wordpress policy” and all other sorts of stuff like that is nonsense. When you actually pay for a product, then you get to complain about it as a “customer”, and only to those whom you pay money to. Until then, either report the bug through correct channels, hopefully along with a fix, or work around the problem. This is Open Source software. If you have a problem, then you can fix it yourself and contribute that fix back to the code.

Viewing 15 replies - 1 through 15 (of 20 total)
  • The topic ‘Cannot select text in text widget’ is closed to new replies.