Support » Plugin: W3 Total Cache » Cannot select cache group theme

  • Resolved realmccoyzz

    (@realmccoyzz)


    I use W3TC at multiple sites.
    After updating to the latest vertion, I can no longer select the “theme” by cache group (user agent group) at the management screen of each site other than the “site network”.
    The selector are grayed out and cannot be operated.
    We can select theme on the “site network” management screen.
    How do I set a cache group theme for each site in the latest version?

    • This topic was modified 4 months, 2 weeks ago by realmccoyzz.
Viewing 13 replies - 1 through 13 (of 13 total)
  • Plugin Contributor Marko Vasiljevic

    (@vmarko)

    Hello @realmccoyzz

    I am sorry about the issue you are experiencing and I am happy to assist you with this.
    Can you please check if the option “Use single network configuration file for all sites” in Performance>General settings>Miscellanious? If the option is checked, uncheck the option and this will allow you to use separate configurations for each website individually.
    I hope this helps!
    Thanks!

    Thread Starter realmccoyzz

    (@realmccoyzz)

    thank you @vmarko

    That option was uncheck.
    ※If checked, the general settings themselves will not be accessible on sites other than the site network.
    There are many other items that cannot be set on sites other than the site network (grayed out).

    • This reply was modified 4 months, 2 weeks ago by realmccoyzz.
    • This reply was modified 4 months, 2 weeks ago by realmccoyzz.
    Thread Starter realmccoyzz

    (@realmccoyzz)

    Plugin Contributor Marko Vasiljevic

    (@vmarko)

    Hello @realmccoyzz

    Thank you for the information.
    Can you please share the screenshot of the Performance>General settings>Page Cache area in the subsite you are trying to configure?
    Thanks!

    Thread Starter realmccoyzz

    (@realmccoyzz)

    @vmarko

    With the following notation, it is grayed out and can not be operated.

    Page Cache
    Enable page caching to decrease the response time of the site.
    Page Cache:	 Enable
    Caching pages will reduce the response time of your site and increase the scale of your web server.
    Page Cache Method:	Disk: Enhanced
    Thread Starter realmccoyzz

    (@realmccoyzz)

    We can now edit the Page Cache by pressing the “Use specific settings” button on the upper right, but we still can’t edit the cache group.

    Plugin Contributor Marko Vasiljevic

    (@vmarko)

    Hello @realmccoyzz

    Thank you for the information.
    Just to confirm when you Use specific settings the Theme dropdown is also greyed out?
    Can you please try enabling the option “Use single network configuration file for all sites” in Performance>General settings>Miscellanious and see if this helps!
    Thanks!

    Thread Starter realmccoyzz

    (@realmccoyzz)

    @vmarko

    Theme dropdown is not greyed out (enable to edit).
    It does not change even if enabling the option “Use single network configuration file for all sites”.
    At that case, only the following options will be displayed in the W3TC “Performance” menu (sites other than the site network).

    1. Dashboad
    2. FAQ
    3. Support
    4. About
    Thread Starter realmccoyzz

    (@realmccoyzz)

    When I checked the source to see why it couldn’t be operated, it was disabled by the code below.

    CacheGroups_Plugin_Admin_View.php
    <input type="button" class="button mobile_delete" value="Delete group" <?php disabled( $useragent_groups['disabled'] ); ?> />

    I searched the entire source of W3TC for “function disabled” but it was not found.

    This is a description that was not in the previous version(0.9.4.1).
    <?php disabled( $useragent_groups['disabled'] ); ?>

    Plugin Contributor Marko Vasiljevic

    (@vmarko)

    Hello @realmccoyzz

    Let me double-check this on a Multisite env and I’ll get back to you.
    Thanks!

    Thread Starter realmccoyzz

    (@realmccoyzz)

    thank you @vmarko
    I use W3TC PRO.
    This symptom occurred when the version was upgraded (0.9.4.1 to 2.2.1).
    In the previous version, it could be set for each site.

    Plugin Contributor Marko Vasiljevic

    (@vmarko)

    Hello @realmccoyzz

    Thank you for the information.
    This is a pretty huge leap when it comes to the plugin version. Can you please try to completely remove and re-install W3 Total Cache and see if that helps, as I am still not able to replicate the problem?
    1. Purge Cache
    2. Deactivate and Delete Plugin
    3. Check .htaccess File (make a backup)
    W3TC will create many directives in the .htaccess file to control the caching behavior. Each section will start and end with comments like “#BEGIN W3TC Page Cache core” and “#END W3TC Page Cache core”.
    Ensure that no residual entries are leftover in your .htaccess file after deleting the plugin.
    4. Delete wp-content files and folders
    – cache folder
    – w3tc-config folder
    – object-cache.php (if exists)
    – advanced-cache.php (if exists)
    – db.php (if exists)
    – upgrade folder
    – delete w3-total-cache folder in wp-content/plugins/ (if exists)
    5. Delete Cached Files from CDN (if using CDN)
    Besides deleting all the relevant files, if you use CDN then ensure to purge the cached content from your CDN. This is necessary when you enabled minify option in W3TC settings. You should delete the minified and combined scripts and CSS files from your CDN server to avoid the site breaking on the browser.
    6. Go to your wp dashboard and re-install W3 Total Cache

    Let me know if this helps!

    Thanks!

    Hello.
    I am having the same problem.
    I removed it once and reinstalled it using the method above.
    But the problem was not solved.

    Multisite WP5.9.2
    W3 Total Cache 2.2.1

Viewing 13 replies - 1 through 13 (of 13 total)
  • You must be logged in to reply to this topic.