Support » Plugins and Hacks » Cannot seem to figure out the Streaming Syntax

Cannot seem to figure out the Streaming Syntax

  • I’ve looked in multiple places and I cannot seem to get CloudFront Streaming to work with the player.

    I have an S3Bucket setup with the cloudfront streaming distrobution. I have tried various versions of syntax liek this:

    [jwplayer file=”rtmp://s3de80tj6557v5.cloudfront.net/cfx/st/mp4:/Video/Bootcamp/Module-1/IntroDayOne.mp4″]

    But nothing seems to every work. Is there any good specifc examples of the wordpress plugin shortcodes and CloudFront anywhere? Do I need to follow the cloudfront instructions of uploading the three player files?

    In all honesty the lack of good “How To Configure” the plugin with Cloudfront is painful. There is plenty of things for HTML embedding code but after 3 hours I’m about to give up.

    Also will streaming even work on an IOS device?


Viewing 15 replies - 1 through 15 (of 16 total)
  • Okay I finally got a stream to work but I cannot figure out the failback to HTML5 for mobile devices:


    [jwplayer file=”mp4:Video/Bootcamp/Module-1/IntroDayOne.mp4″streamer=”rtmp://s3de80tj6557v5.cloudfront.net/cfx/st” provider=”rtmp”]

    But of course it fails on iPad. Is there a way to do HTML5 fallback without making the files open to everyone for security and protecting the content?

    Plugin Author JW Player



    [jwplayer file=”mp4:Video/Bootcamp/Module-1/IntroDayOne.mp4″streamer=”rtmp://s3de80tj6557v5.cloudfront.net/cfx/st” provider=”rtmp”]

    Would be:

    [jwplayer file=”mp4:Video/Bootcamp/Module-1/IntroDayOne.mp4″streamer=”rtmp://s3de80tj6557v5.cloudfront.net/cfx/st” provider=”rtmp” html5_file=”http://www.yoursite.com/video.mp4″]

    I am using JW6 and I got somehwere with this. I also posted just now in the forums:

    I read the html5_file was depricated.


    I am seeing an odd behaviour with the MP4 fallback being loaded in flash and the RTMP being ignored.

    Plugin Author JW Player


    Do you have a link?


    I just updated the short code to this:
    [jwplayer file=”mp4:Video/Bootcamp/Module-1/IntroDayOne.mp4″ streamer=”rtmp://s3de80tj6557v5.cloudfront.net/cfx/st” provider=”rtmp” html5_file=”http://media.v-fit.us/Video/Bootcamp/Module-1/IntroDayOne.mp4″]

    It appears you cannot use the new long string format I had which was:

    Option 1:
    [jwplayer file=”rtmp://s3de80tj6557v5.cloudfront.net/cfx/st/mp4:Video/Bootcamp/Module-1/IntroDayOne.mp4″ provider=”rtmp” html5_file=”http://media.v-fit.us/Video/Bootcamp/Module-1/IntroDayOne.mp4″]

    Option 2:
    [jwplayer file=”rtmp://s3de80tj6557v5.cloudfront.net/cfx/st/mp4:Video/Bootcamp/Module-1/IntroDayOne.mp4″ provider=”rtmp” file=”http://media.v-fit.us/Video/Bootcamp/Module-1/IntroDayOne.mp4″]

    There is a lot of syntax quirks it seems 🙂

    Please let me know the correct one and if the fact you cannot use the others is a bug or working right.

    I still get no iPad HTML5 with any of these options though. At the end of the day I wand RTMP as the main player default and HTML5 for iOS, but I seem to be missing something simple :/


    You can see here it is giving an Error unable to load media file not found. The shortcode is:

    [jwplayer file=”rtmp://stream.v-fit.us/cfx/st/mp4:Video/Bootcamp/AccountabilityDay/AccountabilityReview.mp4″ provider=”rtmp” file=”http://media.v-fit.us/Video/AccountabilityReview.mp4″]

    This tells me the RTMP is being completely ignored by every browser since the HTTP file is in a locked down state for testing so I can prove it’s trying to address the HTML file with a FLASH download. It’s not even playing until the entire file is downloaded so I know it’s not using the RTMP stream like your documentation says it is supposed to do first.

    This is the only syntax I can get the iPad to work, yet the streaming does not kick in on desktop browsers. I think there is either a bug or something missing.

    It’s like I can either only get streaming OR HTML5 fallback but not both, and that feels like a bug of some kind

    It appears to work if you actually do NOT use the short code so I would say adding two file sources in the shortcode is most definately a bug

    <div id=”myElement”></div>
    <script type=”text/javascript”>// <![CDATA[
    playlist: [{
    sources: [{
    file: “rtmp://stream.v-fit.us/cfx/st/mp4:Video/Bootcamp/AccountabilityDay/AccountabilityReview.mp4”
    file: “http://media.v-fit.us/Video/AccountabilityDay/AccountabilityReview.mp4”
    primary: “flash”
    // ]]></script>

    Plugin Author JW Player


    That is because your shortcode above is for JW5, not JW6.

    Then maybe you can be so kind as to help with the correct JW6 short code to properly provide two file sources for rtmp and html5 mp4 fallback. I’ve combed your website and there is nothing to reveal the proper way to do this with the short codes.

    Plugin Author JW Player


    [jwplayer sources=”{ file:’rtmp://stream.v-fit.us/cfx/st/mp4:Video/Bootcamp/AccountabilityDay/AccountabilityReview.mp4′ },{ file:’http://media.v-fit.us/Video/AccountabilityDay/AccountabilityReview.mp4′ }”]

    Awesome I will give that a try in a bit. I have to say that syntax I have not seen until now. I think a good WordPress shortcode doc might be helpful. If this works I can use this and I will get the paid version as well. I did not want to use the script format as it gets whacky when you go from text to visual editor in WordPress :).

    Boo-Ya! Thanks Mate! Maybe we can get some better docs on the plugin usage on the website? I will be sure to blog this out myself since it took a while to get it right! I use Cloudfront for a lot and really am glad I can leverage it for this as well now.

Viewing 15 replies - 1 through 15 (of 16 total)
  • The topic ‘Cannot seem to figure out the Streaming Syntax’ is closed to new replies.