Support » Fixing WordPress » Cannot see any pictures on my blog or when upload to media files

  • Hi

    Since several weeks I cannot see any picture from my blog posts. At the beggining all I couldnt see any picture on the media files. Even do I could upload it I couldnt see the picture afterwards.
    But now, I cannot see any picture from my older blog posts. I tried to clean the cache and also check from another PC but still cannot see the picture.

    My blog is http://www.socialmachinery.com

    I also tried changing the theme and not sucess for seeing my pictures.

    Please could you help me?

Viewing 3 replies - 1 through 3 (of 3 total)
  • Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    🏳️‍🌈 Plugin Review Team Rep

    Your images go to http://wp-content/uploads/2011/01/rsz_picture1.jpg

    They SHOULD go to http://www.socialmachinery.com/wp-content/uploads/2011/01/rsz_picture1.jpg

    In your WP Admin section go to Settings -> Media

    Full URL path to files should be BLANK.

    Hi Ipstenu,

    Thanks for the help…Please be patient as I’m very basic in my knowledge about wordpress.
    As you mentioned somehow the path of the images is incorrect. (Basically the http://www.socialmachinery part should be included to see the images)…Neverthless, when I checked in settings the FULL URL PATH is blank already
    I could change manually the file url path for each image (in the media library section) , but not sure how to do it for all pictures?

    How I could Rectify the FILE URL for all images?

    In the settings sections files are store in
    /home/socialq1/public_html//wp-content/uploads

    Thanks in advanced for your support

    Hi not sure if this helps. I just had a similar problem upon launching a new site. I was able to upload files but couldn’t see them in the pages or posts. File permissions on the directorys were not set to 755 or at least they were not set to ‘public read’ therefore images couldn’t be seen.

    check with your hosting and change file permissions on folders and files if required.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Cannot see any pictures on my blog or when upload to media files’ is closed to new replies.