Support » Plugin: PWA for WP & AMP » cannot save toggle features

  • Resolved joshualevy84

    (@joshualevy84)


    I really like this plugin, but it’s not saving any of the toggle feature buttons. I have tried to switch features on, but after refresh, it slides back,

    Any help will be appreciated.

Viewing 8 replies - 1 through 8 (of 8 total)
  • I also have the same problem.
    There seems to be an error where the button is not displayed.

    Same problem here.

    Plugin Author Magazine3

    (@magazine3)

    Hello,
    Are you using any security plugins to blocking ajax calls?

    if you provide some more detail about the error from a console, its very helpful to recognize the issue.

    we have checked some articles to allow ajax calls click

    Let us know so we can fix the issue.

    No security plugin is used.
    Same issue with my other clean WordPress.
    &
    The save button doesn’t appear,(Appeared and disappeared immediately)
    In configuration modal, I can’t press submit button. (No response when pressed.)
    I am using cloudflare.

    from a console ….

    Uncaught TypeError: $ is not a function
    at HTMLDocument.<anonymous> (admin-pull-to-refresh.js?ver=1.1:2)
    at i (load-scripts.php?c=0&load[chunk_0]=jquery-core,jquery-migrate,utils,jquery-ui-core,jquery-ui-widget,jquery-ui-mouse,jquery-ui-sortable,moxiejs,plupload&ver=5.3:2)
    at Object.fireWith [as resolveWith] (load-scripts.php?c=0&load[chunk_0]=jquery-core,jquery-migrate,utils,jquery-ui-core,jquery-ui-widget,jquery-ui-mouse,jquery-ui-sortable,moxiejs,plupload&ver=5.3:2)
    at Function.ready (load-scripts.php?c=0&load[chunk_0]=jquery-core,jquery-migrate,utils,jquery-ui-core,jquery-ui-widget,jquery-ui-mouse,jquery-ui-sortable,moxiejs,plupload&ver=5.3:2)
    at HTMLDocument.J (load-scripts.php?c=0&load[chunk_0]=jquery-core,jquery-migrate,utils,jquery-ui-core,jquery-ui-widget,jquery-ui-mouse,jquery-ui-sortable,moxiejs,plupload&ver=5.3:2)
    main-script.min.js?ver=1.7.2.1:643 Uncaught TypeError: Cannot read property ‘ajax’ of undefined
    at pwaforwp_ajaxcall_submitdata (main-script.min.js?ver=1.7.2.1:643)
    at HTMLInputElement.<anonymous> (main-script.min.js?ver=1.7.2.1:566)
    at HTMLInputElement.dispatch (load-scripts.php?c=0&load[chunk_0]=jquery-core,jquery-migrate,utils,jquery-ui-core,jquery-ui-widget,jquery-ui-mouse,jquery-ui-sortable,moxiejs,plupload&ver=5.3:3)
    at HTMLInputElement.r.handle (load-scripts.php?c=0&load[chunk_0]=jquery-core,jquery-migrate,utils,jquery-ui-core,jquery-ui-widget,jquery-ui-mouse,jquery-ui-sortable,moxiejs,plupload&ver=5.3:3)
    main-script.min.js?ver=1.7.2.1:572 Uncaught TypeError: $ is not a function
    at datafeatureSubmit (main-script.min.js?ver=1.7.2.1:572)
    at HTMLSpanElement.<anonymous> (main-script.min.js?ver=1.7.2.1:550)
    at HTMLSpanElement.dispatch (load-scripts.php?c=0&load[chunk_0]=jquery-core,jquery-migrate,utils,jquery-ui-core,jquery-ui-widget,jquery-ui-mouse,jquery-ui-sortable,moxiejs,plupload&ver=5.3:3)
    at HTMLSpanElement.r.handle (load-scripts.php?c=0&load[chunk_0]=jquery-core,jquery-migrate,utils,jquery-ui-core,jquery-ui-widget,jquery-ui-mouse,jquery-ui-sortable,moxiejs,plupload&ver=5.3:3)

    We are working on this bug in https://github.com/ahmedkaludi/pwa-for-wp/issues/253

    We will release an update today which should fix this issue.

    Plugin Author Magazine3

    (@magazine3)

    Hello,
    We have fixed this issue in the latest version.

    please update and let us know.

    • This reply was modified 4 months ago by Magazine3.
    joshualevy84

    (@joshualevy84)

    Yes I tried it today it’s working. Can we have option to increase the logo size on the splash screen? Because I think it’s a bit too small on some mobile it would be great it this functionality can be added. Regards

    joshualevy84

    (@joshualevy84)

    Bug confirmed solved for me.

Viewing 8 replies - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.