Support » Fixing WordPress » Cannot ‘Save’ or ‘Publish’ anymore

  • The last post on my blog – – was on the 7th this month, which worked fine. Back then I hadn’t updated WordPress versions yet and used 2.something.

    But then yesterday, prior to install of 2.5, when I wanted to save and continue editing a post, I went from the edit page to which came up completely blank. I hadn’t changed anything since my last post or activity, but this just didn’t work. The post was lost. I tested with some other content, whether I could ‘save and continue’ or ‘save’ and neither worked.

    So I installed WP 2.5 and hoped it would work again. It does not work still, the same problem occurs. I cannot save or publish but when I try, the post is lost and nothing appears on the next page (/post.php). Who knows what the problem is and how to fix it? Many thanks.

Viewing 14 replies - 1 through 14 (of 14 total)
  • We are having the same issue.

    Attempting to publish a PAGE or POST results ina blank post.php – we do get the title saved but nothing else. The PAGE or POST never publishes to the site and stays in draft mode.

    And like yourself – as of 3 days ago – this problem never came up and we were using 2.2 – but then all of our PAGES became POSTS and then you couldn’t post anything. So we upgraded to 2.5 and it did fix the permalinks of the old pages that are now POSTS.

    We are at Dreamhost – I’m not sure it’s related to a server change – but if you note it’s been over a year of no issues then on this forums there are 5+ people with the issue – it’s got to be something.

    I have tried the following:

    1. Upgrading 2.2 – 2.5
    2. Creating a new admin user in 2.5 and seeing if it’s a user permissions problem
    3. turning off mod_security for test in the htaccess file
    4. updated all plugins
    5.deleted cache
    6. updated permalinks (which also resulted in a blank page)
    7. deleted old htaccess file in route and updated with permalinks
    8. Done clean install by deleting everything – then installing plug-ins – etc. and using default theme

    Nothing fixes it.

    What’s interesting is prior to April 9th and I see your last post was April 7th – we had no issues.

    Not a problem since December 2006 until now. Seems the only difference between you and me is that my pages were not converted to posts, it’s just that posts are currently not saved or published. In the old version I used, yesterday drafts weren’t saved at all, but in 2.5 at least the header is, but that then won’t publish either. A nightmare if you ask me.

    I’m with Dreamhost too, with whom I’ve created a ticket as well.

    wow. i am running 2.1.1 on a year-old site. on 2/17/08 i got the same blank page on publish. 2/16/08 was ok.

    i went back to my isp ( not dreamboat note: not a problem on two other sites on this server ) and asked them to restore my database to 2/16. i have bigger problems as a result at the moment.

    but it is interesting everyone getting this for the first time…

    Interesting – yes – the HEADER saves or the POST Title or Page Title saves – but nothing else.

    I had looked in Trac before, but a new search found me these tickets reporting bugs, which seem to address our problem:

    Then I hit upon this topic:

    What I had found before, just dropping that too here, is that there were similar problems reported and fixed about two years and one year ago, of which only one I could find again, here: and follow that through for code, here

    I’m trying to figure out from there what’s what and what may work.

    Wow – I’ll look through these as well. I’ll report back if I get something to work.

    See my latest reply, here:

    Whoohoo! Let us know how you’re getting on?

    This happened to me too and that solution did not work for me. If you go to your Options > Miscellaneous page and the upload directory says something like “/../../../tmp”, then you were hacked. Here is what I found to solve the problem:

    wow, describes my problem(s) to a “T”.

    how does one put a server level password on wp-admin?

    this may be off topic; because of the hack all my pages are posts now. is this fixable? the biggie is my forum behaves like a post. the data is there i just can get to it…

    kzak, thanks much. knowing what the cause is helps with the debugging. btw – how did you find the answer. i posted several times months ago concerning the “//..//” and got no response.

    Hey ron, it took me a while to find the problem. I just started looking at the settings and I noticed that the upload folder had been changed to “/../../../tmp” which looked suspicious. So I started to look at all the wordpress tables in the db and I saw a plugin that I did not add. It contained a .txt file that was sure enough in the ../../tmp directory. I took a look at that file and found it contained the text “Magic Include Shell” along with some malicious php code. I did a search for that in google and found the site linked above.

    To put a server level password on wp-admin, add a .htaccess file. Here’s a site with lots of tutorials on that: 😉

    “We are at Dreamhost”

    blogpire, me too! I am experiencing this very problem right now. Any advice?

    i can’t believe there is a special thread on this issue…


    i JUST found the culprit script in a plugin = commentluv
    i found it via an sql search in wp-opions active plugins

    now i don’t know what to do with it 😉

    kzak = the htaccess tutes did the trick, thank you!

    here is where i am now. i have my sql open > wp-options > active plugins > and up pops the /../… code. can you tell me in layman’s terms what to do next? deactivate plugin? delete it? then reinstall?

    someone also mentioned a default path for plugins. where is that? i could not find it in dashboard > options

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘Cannot ‘Save’ or ‘Publish’ anymore’ is closed to new replies.