Support » Plugin: GamiPress » Cannot save Gamipress achievement settings

  • Resolved Taramin

    (@taramin)



    Hi Ruben,
    I’ve added Gamipress : achievements widget on Member single profile page and I have several issues:
    1. Everytime I try to change the settings and save them, it doesn’t save. For example, I try to add achievement filter, but no luck. The settings are cleared and I have no error message. I’ve tried to clear cache but still, I can’t save the settings. I’ve checked if this might be file permission issue, but it is not.
    2. Only once did I manage to display the filter (I don’t know how however) and the default setting was set on “Display Completed achievements”. However, the filter default setting on page was “Display all”. I didn’t manage to change that whatever I did.

    Can you help me please?

    Regards,

    Devrim

    • This topic was modified 3 months, 2 weeks ago by  Taramin.

    The page I need help with: [log in to see the link]

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author rubengc

    (@rubengc)

    Hi @taramin

    It looks that this issue comes from another plugin that is blocking GamiPress widgets saving

    I tested on different development installs with other plugins like WooCommerce, BuddyPress, and our add-ons, and on all of them I am able to save my widgets correctly

    To debug your issue, can you try the next:

    1. Deactivate all plugins
    2. Activate GamiPress
    3. Go to widgets area and try to save a GamiPress widget
    4. If widgets get saved, try activating another plugin and save again the GamiPress widgets

    Following this steps you will find which plugin is causing the issue

    Best regards

    Hi Ruben,
    Thanks for your answer. One plugin conflicted with Gamipress, indeed.
    However, what about my question aboout the filter? It doesn’t matter the setting I set for the filter, the default value is always “Display all”.
    Thanks,
    Devrim

    Plugin Author rubengc

    (@rubengc)

    Hi @taramin

    I thought the filter value didn’t change by the previous issue, but I was able to reproduce it

    On next release the filter will get fixed and you will be able to set the value you want

    Best regards
    Ruben

    Plugin Author rubengc

    (@rubengc)

    Hi @taramin

    Check the latest GamiPress update, it has a fix for your issue

    I will mark this topic as resolved

    Best regards

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.