Support » Fixing WordPress » Cannot save drafts or edit posts

  • This blog has 109 posts. Twenty of them are affected by this issue. I considered deleting those twenty but cannot even do that.

    For two weeks I have tried all the suggestions in the support forum to resolve this issue to no avail. These are the steps that I have taken, based on the forum suggestions for this issue:

    1. I did a manual install of v. 3.2.1 – problem still exists
    2. I had my host install and enable JSON extension for PHP. They said it was already installed and enabled.
    3. I have repeatedly cleared my cache.
    4. I have deactivated all my plugins – no change
    5. Changed theme to twenty eleven – no change

    I decided to forget the problem and simply enter a new post ignoring the issue regarding editing of old posts. Although the problem is that those 20 posts are accessible for people visiting my blog. Everything appeared to be working fine until I tried to save the draft. It appeared to save. When I logged back in to my wp-admin account the draft was there, I wanted to edit it and could not because all I got was a white page. The only thing on the page was “Edit Post”

    This is a huge time waster for me. I suspect that my best course of action at this time is to start a completely new blog. I’m not confident that a new blog on a new domain using 3.2.1 will work either. Since I am not a programmer, I lack faith in the system.

    Does anyone have further advice for this issue?

  • The topic ‘Cannot save drafts or edit posts’ is closed to new replies.