Support » Plugin: Admin Menu Editor » Cannot save changes – Service Unavailable message

  • Hi,

    I manually updated to WordPress 4.2.1 and AME 1.4.4 (the install is behind a corporate firewall, so I have to do updates manually), and since then when try and save changes in AME, it hangs for a while and then gives me a white page with “Service Unavailable”.

    If I go back into the admin area, nothing is broken, but any changes I made in AME have not been saved.

    I’ve tried deactivating/reactivating the plugin
    I’ve tried uninstalling reinstalling the plugin
    I’ve tried resetting AME using the custom URL you provide
    all to no avail.

    Unfortunately I do not have access to the database (due to it being on a separate database server I do not have access to).

    Any ideas as to what might be happening and what I could do to fix this?

    Thanks in advance!

    https://wordpress.org/plugins/admin-menu-editor/

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Janis Elsts

    (@whiteshadow)

    Check how much memory your site is using. If it’s close to the PHP memory limit, trying to save a new AME configuration could be enough to push it over the edge and crash WordPress.

    You can use this plugin to check memory usage:
    https://wordpress.org/plugins/wp-memory-usage/

    Hey, thanks for the response.

    Memory Usage reports 20.1/1024, essentially 2% memory used even when people are browsing the site. It doesn’t seem to be related to memory.

    The plugin reports: PHP Version : 5.4.5 / 64Bit OS

    Any other ideas?

    Plugin Author Janis Elsts

    (@whiteshadow)

    The next thing to check would be server logs. Specifically:

    • Check the PHP error log. Are there any errors or warnings that show up when you try to save the menu?
    • If your server is running mod_security, Suhosin or other security/intrusion detection software, check those logs as well. In rare cases, incorrectly configured security tools can prevent AME from saving menu settings.*
    • Check Apache/nginx error logs. Are there any error messages that mention the menu editor URL? (options-general.php?page=menu_editor)

    * For example, one user reported that they couldn’t save the menu because their server was configured to reject any request that contains the keywords “update” and “set” (probably as a way to protect against SQL injection). The menu configuration happens to contain those keywords as part of menu titles (e.g. “Dashboard -> Updates” and “Settings”), so the “save changes” request got blocked.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Cannot save changes – Service Unavailable message’ is closed to new replies.