Support » Plugin: Media Library Assistant » Cannot save categories

  • I am unable to add new categories to media items and in checking my server logs I see the following:

    PHP Warning: array_merge(): Argument #2 is not an array in /home/site12/web/wp-includes/post.php on line 3644, referer: http://www.mydomain.com/wp-admin/post.php?post=882&action=edit&mla_source=edit

    Any idea of what could be causing this problem and what to do?

Viewing 10 replies - 1 through 10 (of 10 total)
  • Plugin Author David Lingren

    (@dglingren)

    Thanks for your report. I regret the trouble you’re having with assigning categories to media items.

    I just ran a quick test on my own system and (of course) I had no problems adding a new term to the “Att. Categories” taxonomy. I tried just checking an existing term and using the “+ Add New Category” feature to define a new term.

    Thanks for posting the PHP Warning message from your error log; very helpful. I can see in the post.php code that “Argument #2” should be an array of updates to the post, including the taxonomy term assignments.

    I would like to know a few more things so I can try to reproduce your problem:

    1. Are you using the “Media\Edit Media” full-screen edit for this operation? If not, where are you making your updates from?
    2. What taxonomy are you trying to update?
    3. Are you simply checking an existing term or adding a new term?
    4. If you are checking an existing term, can you use the Media/Assistant admin screen’s Bulk Edit or Quick Edit without causing the error?

    Thanks for any additional information you can provide!

    Thread Starter Michael Aronoff

    (@masterk)

    Thanks for the quick response. Let me answer them in order.

    1. Yes, I am using the full screen “Media\Edit Media” from the for the operation.
    2. I have tried to update in many ways. I have tired adding a new cat and I have tried adding an existing to a media item that already has some assigned. along with some other permutations for trouble shooting. All show the same result.
    3. As I mentioned in #2 I have tired adding an existing term and adding a new one.
    4. I had not tried Bulk Edit so I just did and it worked! I still cannot add at the regular “Media\Edit Media” screen but I can add and remove if I check an item and then choose “edit” from bulk actions and click apply. Strange.

    I also tried changing my PHP version just to make sure it was not a problem with php7.1 but the problem was the same on php5.6

    Plugin Author David Lingren

    (@dglingren)

    Thanks for your thorough testing and reporting!

    I am happy to hear the Bulk Edit feature works. You might also find that the Quick Edit rollover action also works, and is easier to use than the multi-step Bulk Edit for one item.

    The MLA Bulk Edit and Quick Edit features use a different code path to update taxonomy terms – they don’t go through the WordPress wp_update_post function if all you change is taxonomy term assignments.

    In fact, the Media/Edit Media screen updates do not usually involve MLA at all, and the symptom you reported would happen for any changes, not just taxonomy terms. I regret that I must ask more questions:

    1. Are you able to change other fields, e.g., Caption, Alternative Text or Description?
    2. Do the Bulk Edit and Quick Edit functions work if you change something else, e.g., Caption or Description?
    3. Do you have other plugins that add features to the Media/Edit Media screen?

    My system runs PHP 7.0, which is slightly less strict than 7.1 but more strict than 5.6. If further testing doesn’t yield an answer I can work with you to add some debug logging that might reveal more details. Thanks for your persistence.

    Thread Starter Michael Aronoff

    (@masterk)

    1. I am not able to edit other fields in the full post edit screen. I had not even tried. It works in the Quick Edit mode.

    2. I do not see Media Categories as an item I can edit in the Quick Edit mode. Is that a setting I missed?

    3. I do not have any other plugins that I think would hook into the Media item edit screen.

    I am happy to add some debug code to help see if we can find the problem.

    Plugin Author David Lingren

    (@dglingren)

    Thanks for your continued testing. One last question occurs to me; if you disable MLA, does the Media/Edit Media screen work properly? You won’t see the taxonomies, but fields like Caption should work.

    The best way to proceed is by email. If you send me your contact information I will reply with more details and an address where you can send test results. You can use the Contact Us page at our web site:

    Fair Trade Judaica/Contact Us

    Thanks for your understanding and your patience.

    Thread Starter Michael Aronoff

    (@masterk)

    I will contact you off list, but I wanted to post here that I found the conflict.

    Canonical Attachments was also in use on the site and that was the conflict. Once I disabled that everything started working again properly.

    I still will contact you in case you would like to try and figure out the conflict from your side but if not I understand that too.

    Plugin Author David Lingren

    (@dglingren)

    Thanks for contacting me and for identifying Canonical Attachments as the source of your problem. I was able to verify your problem and I have reported it in the other plugin’s support forum.

    I am leaving this topic resolved. Thanks for your help and for your interest in MLA.

    Hi Michael @masterk, I apologize that my plugin caused you some headaches.

    David @dglingren, Thank you so much for reporting this issue to me. I have updated the Canonical Attachments plugin. Can you confirm that this has eliminated the conflict?

    Thanks,

    Jake @jblifestyles

    Plugin Author David Lingren

    (@dglingren)

    Thanks, Jake, for your update. I am travelling until December 11, but I will check on this after I return home.

    Plugin Author David Lingren

    (@dglingren)

    I have done some testing with your new plugin version and reported my findings here:

    Plugin Prevents Updating Media

    It looks like the problem reported in this MLA topic has been resolved. Thanks for your prompt attention to the issue.

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Cannot save categories’ is closed to new replies.