Support » Fixing WordPress » Cannot remove widgets

  • There are widgets in my sidebar that I cannot get rid of. In fact – There are (apparently) 5 widgets in use in the sidebars total (links, archives, categories, meta and recent articles) but when I go to the page where I am supposed to be able to add or remove them – all of these show up in available widgets, but not under the sidebar as being in use. In the instructions, I am supposed to see them in the Sidebar 1 or Sidebar 2 and drop and drag it out (back to available widgets) if I don’t want it in my sidebar. But both Sidebar spaces are blank, which means I cannot “drop and drag” them out of the sidebar to remove it. Is there any way to resolve this? I am using the WP theme called Live by Herdo, if that helps, any. Thanks.

Viewing 12 replies - 1 through 12 (of 12 total)
  • Is this the theme?


    Please check from the wordpress admin area and if anyone widget is not added then it should be loading the default widget of the theme. In order to remove them you either need to remove it from the sidebar.php file of your theme or add any widget from admin panel.

    Also check with disabling the plugins.


    Shane G.

    Yes, that is the theme I am using. It seems that my “widgets” program is not working properly. I can drag a widget from the “available widgets” area into a sidebar then save it. Then the widget will not be there in the sidebar for if I want to remove it. When I preview the site – it may or may not be there, it does not seem to matter if I move it in or out. Sometimes a new widget I drop and drag in might replace one I did not want replace and sometimes both will be there – it just seems to have a mind of its own. I have been playing with it and two of them I cannot remove. I could go through the sidebar.php file, but I don’t know css well enough to remove the right thing. Then I do not know how to replace it with the one I want. Any ideas? Thanks.

    I’m sorry – I know this sounds confusing so I wanted to just add one more example… I have a “categories” widget that shows up in the right column. In my admin/widgets area, this widget is in the “inactive widgets” area. It is supposed to be in the “sidebar 2” because it is active. In fact – no matter what widget I drop and drag into the sidebars, as soon as I “view my site,” then go back to the admin area – the widget is gone either into the inactive area or the area to choose from when it should be in the sidebar where it was placed. I hope this helps to clarify. If anyone could guide me I would really appreciate it. Thank you.

    I just installed this theme to see how it handles widgets.

    If you don’t have any widgets installed the theme will automatically place the 5 hardcoded, “default” widgets between the two sidebars.

    If you have at least one widget installed in one of the sidebars then it will only display that widget.

    Do you not want to display any widgets? If so, just place a blank Text widget into each sidebar.

    If not, drag whichever widgets that you want into the sidebar that you want. The refresh the widget page to make sure the widgets saved and then view your site again.

    First I want to say, thank you sooo much for replying so quickly. This is very frustrating for me. I did notice that it will display default widgets and will replace them when I add widgets. However, even after I “save,” the widgets will appear and disappear. (For example, I’ll go to “visit site” and see the widget, go back to the admin page and it is gone, so go back to check on the “visit site” and sure enough, it is gone.) Also, I believe the widgets that I add should be displayed in the Sidebar 1 or Sidebar 2 as a bar that I can drop and drag out, but even after I drop and drag a widget in, once I save and go to “visit the site” the widget disappears and the Sidebar spaces are once again blank. It cannot seem to “hold” any of my choices. (I am sorry if this sounds so confusing.) Perhaps I am saving wrong? I press the “save” button, should I then click the refresh button after this? Thanks, again. I appreciate your help.



    Forum Moderator

    Have you tried:

    – deactivating all plugins to see if this resolves the problem? If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    – switching to the default theme to rule out any theme-related problems?

    Yes – I did deactivate all of the plugins and it did not help, after I go to view the site the go back to the admin area, the same thing, sidebars are blank and almost every widget is in the available area and the inactive area. Switching the theme? hmmmmm……. I will try that now and let you all know what happens. Thank you for that.

    Okay – I changed to the default theme and pretty much the same thing happens. I dropped and dragged the widget “text” to Sidebar 1 (the only sidebar on the default theme), saved then went to “visit site.” All widgets were now gone (I assume they were all default) then I went back to my admin page and the Sidebar was empty. So I added the “categories” widget, saved and then “visit site.” The categories was there. So I went back to the admin page and the sidebar was empty – but there were 4 “category” widgets in the inactive file. This should not be inactive as I do have categories. I tried another theme (called Deep Blue) and it does seem to save the widgets in the sidebar.

    So does this mean both the Live and default themes do not work for widgets? I am confused. Also, is there any way to contact the designer of the theme? When I go to the author site, it says to contact through a comment, but it looks like that has not been used for some time.

    thank you for any help.



    Forum Moderator

    The default theme is fully widget-ready. The fact that you still had a problem with widgets when using the default theme suggests that the problem is elsewhere. Plugins still have to be high on the list of possible culprits. Try resetting the plugins folder by phpMyAdmin. Sometimes, an apparently inactive plugin can still cause problems.

    Thank you for that – I did suspect the problem was outside the theme… so after switching themes a couple times, now it seems to hold the widgets. But not sure if that will last. I need to add more widgets, so if it does this again, I will try resetting it. I’ll let you all know what happens. Thanks, again.

    ok, can you mark this thread as resolved?

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘Cannot remove widgets’ is closed to new replies.