Support » Plugin: Custom Post Type UI » cannot remove page title

  • Resolved tvalleau

    (@tvalleau)


    Created several Custom Post Types, such as “video” and “memberphotographer” and have a hundred or so posts of those types. ALL of them show the page title, no matter that we have the page title to be hidden site-wide, in our theme, Avada. The page title IS hidden, UNLESS that post has a CPT, such as “video” or any of the other CPTs.

    Have been through all the settings in CPT and cannot find one controlling the display of the page title.

    Is there any way to change the code of our CPT types to force the page title to NOT show?

    sample page: https://photography.org/membphotog/mary-aiu/

    The page I need help with: [log in to see the link]

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author Michael Beckwith

    (@tw2113)

    The BenchPresser

    hi @tvalleau

    We don’t have any settings in our plugin specifically around Avada, so I have a feeling anything regarding this is going to be more on Avada’s side.

    That said, do you have Fusion Builder enabled for your post types? I know I found https://theme-fusion.com/documentation/fusion-builder/settings-tools/fusion-builder-custom-post-types/ which may enable extra settings for your post type posts including possible page title control for them.

    Hi Michael. Thanks for the prompt response. I use Fusion Builder on all the pages. I’m not really asking if you have a special control for Avada, but rather why CPT -over rides- the Avada setting to hide all titles.

    Avada already DOES have control over title visibility. I have it set to OFF, but CPT is over-riding that, and showing the titles anyway. I’ve already tried repeating the “hide” command in Fusion Builder, but since CPT is ignoring the system-wide command to hide the title bar, and displaying it come what may, it came as no surprise that Fusion Builder (a part of Avada) equally had no effect on CPT.

    Here’s the problem. The page title bar is how entries are listed in the admin view. If I disable it entirely in CPT, I get a listing of pages that looks like this in admin mode:
    (no title)
    (no title)
    (no title)
    (no title)
    (no title)
    (no title)
    (which makes finding a given photographer’s page a little difficult 🙂

    So I cannot completely disable the titlebar in CPT. But since CPT -insists- on showing it if it is enabled, then each page looks like this when we add the name as a headline:

    Bill Smith
    Bill Smith

    Jill jones
    Jill jones

    So I was hoping there was some way to get CPT to honor the site-wide “hide title bar” setting, instead of over-riding it.

    I have tried changing the size of the text of the title, but because I have titles turned off site-wide, that also has no effect. CPT-in-Avada shows the page title at a fixed size, and near as I can tell, the only control CPT offers is “either you get a title or you don’t.”

    Thanks anyway, I guess… 🙂

    Plugin Author Michael Beckwith

    (@tw2113)

    The BenchPresser

    Best I can offer is talking to Avada support, because it’s all them that’s handling the display of your frontend. It’s nothing inherent about post types in general or some detail about your post types specifically through CPTUI that’s causing it. It’s all in Avada’s theme logic here.

    Based on what I can infer from a copy I was able to access, you’re wanting to adjust the “Blog > Post Title” setting shown in the screenshot below:

    Screen Shot

    Setting to below or above will show the title markup. Setting it to disabled will not. If anything, worth a try tinkering with this specific setting. For information sake, I found the spot I reference dependent on that setting, in the single.php file. Unsure if you would want to crack open some PHP files to see what’s all in there.

    Thanks again, Michael. You’ve spent enough time on this. If you want to see what I’m trying to overcome, click on the link in the first post.

    My best solution is to leave the title (the first “Mary Aiu”) in place, since I cannot control it, and to delete the actual page headline (the second name) entirely. I lose left margin alignment, but at least I don’t have the same name appearing twice!

    I appreciate your suggestions.

    Plugin Author Michael Beckwith

    (@tw2113)

    The BenchPresser

    The setting I highlighted would actually remove the first one, based on what digging I’ve done. That sounds like what you’re trying to do.

    Don’t worry about the time aspect.

    Bingo!
    It never occurred to me to look under blog single post. Nice find, and saves me having to muck about with over 100 individual pages!

    Thanks. Another tool in my belt 🙂

    Plugin Author Michael Beckwith

    (@tw2113)

    The BenchPresser

    Yeah, it’s not the most obviously labeled to include post types, but there we go. Glad I could help. 🙂

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘cannot remove page title’ is closed to new replies.