Support » Plugin: Sucuri Security - Auditing, Malware Scanner and Security Hardening » Cannot redeclare class SucuriScanSiteCheck

  • Resolved cedwardsmedia

    (@cedwardsmedia)


    I logged into my WordPress site today to discover this notice from Sucuri. The only thing that’s recently changed was enabling Xcache for PHP. I disabled it to see if it was the culprit but nothing changed. I’m not quite sure why this particular issue is arising.

    Fatal error: Cannot redeclare class SucuriScanSiteCheck in /var/www/wordpress/wp-content/plugins/sucuri-scanner/sucuri.php on line 13555

    https://wordpress.org/plugins/sucuri-scanner/

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author Daniel Cid

    (@ddsucurinet)

    Do you have a duplicated copy of the plugin in there? Was anything else installed or updated? That’s the only thing I can think of.

    thanks,

    Is there a solution for that issue? I have the same problem and i can say that there is no duplicate folder of Sucuri Security. This is a new installation. My WP version is 4.6. I have scanned the whole installation (htdoc directory) for the class definition. The result was: `grep -R SucuriScanSiteCheck *
    wp-content/plugins/sucuri-scanner/sucuri.php: && SucuriScanSiteCheck::isDisabled()
    wp-content/plugins/sucuri-scanner/sucuri.php: && SucuriScanSiteCheck::isDisabled()
    wp-content/plugins/sucuri-scanner/sucuri.php: $params[‘Settings.SiteCheckStatus’] = SucuriScanSiteCheck::statusPage();
    wp-content/plugins/sucuri-scanner/sucuri.php: $params[‘Settings.SiteCheckCache’] = SucuriScanSiteCheck::cachePage($nonce);
    wp-content/plugins/sucuri-scanner/sucuri.php: $params[‘Settings.SiteCheckTimeout’] = SucuriScanSiteCheck::timeoutPage($nonce);
    wp-content/plugins/sucuri-scanner/sucuri.php:class SucuriScanSiteCheck extends SucuriScanSettings
    wp-content/plugins/sucuri-scanner/sucuri.php: if (SucuriScanSiteCheck::isDisabled()) {
    `

    Plugin Author Daniel Cid

    (@ddsucurinet)

    Can confirm the issue is xcache on PHP. Have you enabled it recently?

    I also encounter the issue, but after upgrading WordPress to 4.6.1 and subsequently Sucuri to 1.8.1 – xcache settings were not changed. Do you have a workaround?

    I moved my wordpress installation to new domain , now i get this error

    Plugin could not be activated because it triggered a fatal error.
    Fatal error: Cannot redeclare class SucuriScanSiteCheck in /var/www/clients/client0/web1/web/wp-content/plugins/sucuri-scanner/sucuri.php on line 13555

    can xcache cause this problem. its installed on new host
    should I remove it,

    • This reply was modified 2 years, 10 months ago by  saajanbedi.

    I have the same problem withe WordPress 4.6.1. so, i returned into 4.5.4 and it’s the same : Fatal error: Cannot redeclare class SucuriScanSiteCheck in /var/www/web6/web/i2mA/wp-content/plugins/sucuri scanner/sucuri.php on line 13555

    Do you have an issue ?

    I have no cache. It’s a first installation with theme the7. I obtain this error with ou without other plugins activated.

    This issue was fixed with commit #632ee1b [1].

    [1] https://github.com/Sucuri/sucuri-wordpress-plugin/pull/28/commits/632ee1b

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Cannot redeclare class SucuriScanSiteCheck’ is closed to new replies.