WordPress.org

Forums

WordPress Popular Posts
Cannot redeclare array_merge_recursive_distinct() (2 posts)

  1. younten
    Member
    Posted 1 year ago #

    I get the following
    Fatal error: Cannot redeclare array_merge_recursive_distinct() in wp-content/plugins/wordpress-popular-posts/admin.php on line 11

    I had just updated to version 2.3.7

    http://wordpress.org/plugins/wordpress-popular-posts/

  2. Hector Cabrera
    Member
    Plugin Author

    Posted 1 year ago #

    Hi there,

    It's really weird that no one had reported this before (and I was pretty sure I fixed that before pushing version 2.3.7... damn...).

    Here's a quick -and really hacky- temporary fix to correct the issue:

    1. Go to Settings > Plugins.
    2. Find WordPress Popular Posts and click on Edit.
    3. On the Editor page, click on admin.php.
    4. Find array_merge_recursive_distinct and rename it to something like array_merge_recursive_distinct2 (the function is called three times on admin.php, make sure you rename it everywhere).
    5. Save changes.

    This error is already properly fixed on WPP 3.0.0, which is still a work in progress.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • WordPress Popular Posts
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic