Support » Plugin: SVG Support » Cannot put SVGs into media gallery

  • Resolved Tobias Eichner

    (@tobiaseichner)


    Hi,

    when trying to create a media gallery (with WordPress built-in gallery, no plugin), I’m able to add the SVG files into the gallery and they appear correctly when being in edit mode (using tiny MCE editor).

    However, previewing the webpage, the SVG files do not show up. On mixed galleries, other file types (like JPG or PNG) show, but SVG don’t.

    Do you have any idea where to look at ?

    Kind regards,
    Tobias.

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Benbodhi

    (@benbodhi)

    Hey there,

    Sounds like you might just need to set a width with CSS.

    A blanket declaration you could use would be this, but you can get more selective if you want:

    img[src$='.svg'] {
        width: 100%;
    }

    If you provide a link, I can take a look.

    • This reply was modified 1 year, 3 months ago by  Benbodhi.

    Yes, this was the problem. All SVGs had no dimension settings. Thank you very much ! 🙂

    Plugin Author Benbodhi

    (@benbodhi)

    My pleasure 🙂

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Cannot put SVGs into media gallery’ is closed to new replies.