Support » Fixing WordPress » Cannot publish with fresh install

  • Hello, I have just done a fresh installation and cannot edit or publish pages or posts. Here are the error messages I get:

    Publishing failed. Error message: The response is not a valid JSON response.

    Updating failed. Error message: The response is not a valid JSON response.

    Here is the output of the Health Check plugin:

    
    <blockquote>### wp-core ###
    
    version: 5.3.2
    site_language: en_US
    user_language: en_US
    permalink: /%year%/%monthnum%/%day%/%postname%/
    https_status: true
    user_registration: 0
    default_comment_status: open
    multisite: false
    user_count: 1
    dotorg_communication: true
    
    ### wp-paths-sizes ###
    
    wordpress_path: /var/www/us-discovery/wordpress
    wordpress_size: 37.88 MB (39718745 bytes)
    uploads_path: /var/www/us-discovery/wordpress/wp-content/uploads
    uploads_size: 4.70 KB (4813 bytes)
    themes_path: /var/www/us-discovery/wordpress/wp-content/themes
    themes_size: 4.21 MB (4413234 bytes)
    plugins_path: /var/www/us-discovery/wordpress/wp-content/plugins
    plugins_size: 563.51 KB (577037 bytes)
    database_size: 1.69 MB (1769472 bytes)
    total_size: 44.33 MB (46483301 bytes)
    
    ### wp-active-theme ###
    
    name: Twenty Twenty (twentytwenty)
    version: 1.1
    author: the WordPress team
    author_website: https://wordpress.org/
    parent_theme: none
    theme_features: automatic-feed-links, custom-background, post-thumbnails, custom-logo, title-tag, html5, align-wide, customize-selective-refresh-widgets, editor-color-palette, editor-font-sizes, widgets, menus, editor-style
    theme_path: /var/www/us-discovery/wordpress/wp-content/themes/twentytwenty
    
    ### wp-themes-inactive (3) ###
    
    Twenty Nineteen: version: 1.4, author: the WordPress team
    Twenty Seventeen: version: 2.2, author: the WordPress team
    Twenty Sixteen: version: 2.0, author: the WordPress team
    
    ### wp-mu-plugins (1) ###
    
    Health Check Troubleshooting Mode: author: (undefined), version: 1.7.0
    
    ### wp-plugins-active (1) ###
    
    Health Check & Troubleshooting: version: 1.4.2, author: The WordPress.org community
    
    ### wp-plugins-inactive (2) ###
    
    Akismet Anti-Spam: version: 4.1.3, author: Automattic
    Hello Dolly: version: 1.7.2, author: Matt Mullenweg
    
    ### wp-media ###
    
    image_editor: WP_Image_Editor_Imagick
    imagick_module_version: 1690
    imagemagick_version: ImageMagick 6.9.10-23 Q16 x86_64 20190101 https://imagemagick.org
    imagick_limits: 
    	imagick::RESOURCETYPE_AREA: 122 MB
    	imagick::RESOURCETYPE_DISK: 1073741824
    	imagick::RESOURCETYPE_FILE: 768
    	imagick::RESOURCETYPE_MAP: 512 MB
    	imagick::RESOURCETYPE_MEMORY: 256 MB
    	imagick::RESOURCETYPE_THREAD: 2
    gd_version: 2.2.5
    ghostscript_version: 9.27
    
    ### wp-server ###
    
    server_architecture: Linux 4.19.0-6-amd64 x86_64
    httpd_software: Apache
    php_version: 7.3.11-1~deb10u1 64bit
    php_sapi: fpm-fcgi
    max_input_variables: 1000
    time_limit: 30
    memory_limit: 256M
    max_input_time: 60
    upload_max_size: 2M
    php_post_max_size: 8M
    curl_version: 7.64.0 OpenSSL/1.1.1d
    suhosin: false
    imagick_availability: true
    server-headers: 
    	date: Mon, 30 Dec 2019 21:12:49 GMT
    	server: Apache
    	expires: Wed, 11 Jan 1984 05:00:00 GMT
    	cache-control: no-cache, must-revalidate, max-age=0
    	link: <https://us-discovery.com/wp-json/>; rel="https://api.w.org/"
    	upgrade: h2,h2c
    	vary: Accept-Encoding
    	content-encoding: gzip
    	content-length: 9070
    	content-type: text/html; charset=UTF-8
    htaccess_extra_rules: true
    
    ### wp-database ###
    
    extension: mysqli
    server_version: 10.3.18-MariaDB-0+deb10u1
    client_version: mysqlnd 5.0.12-dev - 20150407 - $Id: 7cc7cc96e675f6d72e5cf0f267f48e167c2abb23 $
    
    ### wp-constants ###
    
    WP_HOME: undefined
    WP_SITEURL: undefined
    WP_CONTENT_DIR: /var/www/us-discovery/wordpress/wp-content
    WP_PLUGIN_DIR: /var/www/us-discovery/wordpress/wp-content/plugins
    WP_MAX_MEMORY_LIMIT: 256M
    WP_DEBUG: false
    WP_DEBUG_DISPLAY: true
    WP_DEBUG_LOG: false
    SCRIPT_DEBUG: false
    WP_CACHE: false
    CONCATENATE_SCRIPTS: undefined
    COMPRESS_SCRIPTS: undefined
    COMPRESS_CSS: undefined
    WP_LOCAL_DEV: undefined
    
    ### wp-filesystem ###
    
    wordpress: writable
    wp-content: writable
    uploads: writable
    plugins: writable
    themes: writable
    mu-plugins: writable
    
    

    Thank you!

    The page I need help with: [log in to see the link]

Viewing 2 replies - 1 through 2 (of 2 total)
  • Hi @tedfolkman,

    I hope this message finds you well. Based from the information you provided it appears that this is related to the core files of WordPress. Please try downloading WordPress again, access your server via SFTP or FTP, or a file manager in your hosting account’s control panel, and delete then replace your copies of everything except the wp-config.php file and the /wp-content/ directory with fresh copies from the download. This will effectively replace all of your core files without damaging your content and settings.

    Some uploaders tend to be unreliable when overwriting files, so don’t forget to delete the original files before replacing them.

    Kind regards,

    Thread Starter TJF27

    (@tedfolkman)

    @jraborar thanks for the response! I downloaded the latest.zip and replaced all the core files, and the same error occurred. Further investigation, though, showed that when I installed the Classic Editor plugin, I was able to create and modify posts. (The entire point of my new installation was to experiment with the block editor). Any thoughts?

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Cannot publish with fresh install’ is closed to new replies.