Support » Fixing WordPress » Cannot publish posts nor save drafts

  • Resolved MaXiWi


    Hi there!

    I’m running 4 blogs with WordPress on the same site (host: 1&1) with different versions: 2.9.1, 2.7.1., 2.7. and 2.6.
    Yet they all have in common that I am no longer able to publish posts or save drafts. Moreover, the permalink bar below the post title is gone. When I press the publish button I automatically will be redirected to the Edit Posts page (edit.php) but the new article will not be there or in the draft section.
    I’m encountering this problem for a couple of weeks now without having updated any wordpress version in the first case. Now, that I made an update at my one blog (2.8. to 2.9.1.) the whole thing won’t change though I hoped it would resolve the problem.
    I also deactivated all plugins and changed the theme to the default but it didn’t work either.
    I also noticed that I am no longer able to make changes to the general preferences section. Beyond that I am not able to upload any image no matter what size it has. The process will stop short after I’ve hit the upload button. So maybe this is a hint, too.

    Nevertheless, I am absolutely clueless where this problem might originate from because it appeared without having made changes to any of my 4 blogs.

    Thanx in advance for your help!

Viewing 5 replies - 1 through 5 (of 5 total)
  • esmi


    Forum Moderator

    1. If you have access to your PHP.ini file, change the line in PHP.ini
    If your line shows 16M try 32M:`
    memory_limit = 32M ; Maximum amount of memory a script may consume (32MB)`

    2. If you don’t have access to PHP.ini try adding this to an .htaccess file:
    php_value memory_limit 32M

    3. Try adding this line to your wp-config.php file:
    Increasing memory allocated to PHP
    define('WP_MEMORY_LIMIT', '32M');

    4. Talk to your host.

    Thanks for your quick answer!!!

    Could you please tell me where I will find the PHP.ini file? Is it hidden somewhere in the PHPMyAdmin or in the wordpress directory on my server?
    By the way, will the changes that I should make to the PHP.ini file resolve the whole problem or just the one with the images?

    I will definitely talk to my host but I guess he will say that it’s none of his business as it is me who decided to use WordPress which is nothing 1&1 is responsible for. What exactly should I ask my host for? Is this problem a database issue which can only be resolved by altering some preferences by my host?

    Anyway, thanks for the help!!! I’ll try my best! 😉

    I added the indicated lines to the .htaccess and wp-config.php files respectively but to no avail. Now I get a Error 500 – Internal server error. Maybe I added them at the wrong line?
    Does it matter where I put the php_value memory_limit 32M in the .htaccess?
    And what about the define('WP_MEMORY_LIMIT', '32M');?
    Should I put it below the // ** MySQL settings ** // thing?

    Moreover, I went through the help pages of my host and found that the default setting of the memory limit is 40MB. But if I used a php.ini, which is not the case, it would reduce to 8MB. Well, I don’t get that…



    Forum Moderator

    If the default setting of the memory limit is 40MB, it’s less likely to be a memory issue, so remove php_value memory_limit 32M from .htaccess and define('WP_MEMORY_LIMIT', '32M'); from wp-config.php.

    I would have thought that chance of 4 databases being damaged at the same time was pretty low too – although you could always check and see if any tables need repairing.

    Have you tried:

    resetting the plugins folder by FTP or phpMyAdmin? Sometimes, an apparently inactive plugin can still cause problems.

    – re-uploading the wp-admin and wp-includes folders from a fresh download of the appropriate version of WordPress?

    I’d also recommend that your older blogs are updated to 2.9.1 as soon as possible.

    The problem is solved!!! 😉

    I talked to my host and he told me that I was exceeding the memory limit of my database by around -46MB (I’ve got 100MB in total).
    Well, now I’m trying to migrate one of my blogs to the second database and once again I’m running into troubles… The backuped SQL database won’t import because of syntax errors and unknown punctuation. o_O
    Oh my! -_-;;

    Thanks for the patience and the great help anyway!!!

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Cannot publish posts nor save drafts’ is closed to new replies.