Support » Fixing WordPress » cannot publish at all

  • Hello,

    i recently upgrade to V 2.2.2 and when i click on publish, it doesn’t publish at all. i have clear my cache and cookies. the post goes into draft instead.

    i notice when i click on the to nav bar for Users, i get this error message:

    Fatal error: Unsupported operand types in /home/fusionrain/blog/wp-admin/users.php on line 55

    thank you.

Viewing 15 replies - 1 through 15 (of 16 total)
  • Same problem. 🙁

    Plus in ‘Your Profile’ tab I get all empty fields automatically filled up with ‘Array’ (obviously an error calling the variable)

    Not much found in Google yet, but some other users are having the same problem. A buggy WP2.2 version?

    Me again. I develop my projects in localhost and then upload them to my host, copying the files and exporting the DB.

    The default language for the contents is Spanish (not the WP distro, that remains in English). I found some people with this very same problem are Germans. Could it be a character encoding problem, when exporting the DB?

    Just guessing. Not much time now to look for a solution. 🙁 Maybe in a few days time.

    $this->first_user = ($this->page - 1) * ($this->users_per_page);

    This is the
    /home/fusionrain/blog/wp-admin/users.php on line 55
    giving the error.

    I’ve doublechecked the syntax but it seems allright.

    Any idea?
    Should we open a bug?

    Thank you for any advice,
    hip

    Having the same error here too.

    Along with the “array” problem and the widgets admin spewing JS errors. Even after a completely new install :-/

    Any updates on this. I have this issue on a fresh install.

    I have same problem with publish button not working – post just stays as draft. Also any new post created in V2.2 and saved as draft has the term ‘Array’ populated in the password field – in the right hand column. So the post is now password protected??

    I’ve gone back to V2.1 just so I can publish new posts 🙁

    Again. v2.2 fresh install and get the same error. It runs ok in localhost (Apache/2.0.55 (Win32) PHP/4.3.10) but not on production server (Apache v.? (i686-redhat-linux) PHP/4.3.9)

    JS errors in ‘Write’ (post/page) & ‘Manage’ sections:

    Error: tinyMCE is not defined
    Source File: wp-admin/post-new.php
    Line: 191

    Error: edToolbar is not defined
    Source File: wp-admin/post-new.php
    Line: 154

    PHP errors in ‘Errors&Users’:

    Fatal error: Unsupported operand types in /var/www/vhost/blahblah.com/wp-admin/users.php on line 55

    I just upgraded last night. Along with all the Array crap in the plugins area and in any blank field, I realized tonight I could not post as either. It saves it as draft and put array in password field as well as slug. I erased those and tried to publish still no go. Anyone have a clue?

    It seems to be a PHP & mySQL & Zend versions cocktail issue:

    http://wordpress.org/support/topic/118367

    It should anyway be announced by the WordPress team next to the new WP version download link. And doublecheck this issue for the following WP updates.

    You may try upgrading your PHP, mySQL & Zend Optimizer in order to bring your blog back to work.

    erika_conn

    (@erika_conn)

    I’m having the same problem. I am sorry I ever upgraded.
    Has anyone found a solution? Even my Dashboard doesn’t look right.

    In my case, this error was a consequence of the ‘array’ error.

    See here for the solution:

    http://wordpress.org/support/topic/118367?replies=41

    I’m having the same problem. My first WP installation, it all looked fine, untill I tried to publish – it stayed as a draft 🙁

    Has anyone come up with a solution?

    It just “happened” that I couldn’t publish anything when I updated the xmlrpc.php file at the suggestion of technorati. I used 2.05. I updated another blog on another server and it worked fine. So, I upgraded to WP 2.5. Everything looks fine except when I click Save or Publish, I get a blank browser page and nothing is published. I’ve haunted these forums without success. Anyone know what’s happening here?

    I have the same problem that Jnardo. I upgraded to 2.5 and I’getting a blank browser when I try to publish…

    Has anyone found a solution?

    I too have the same problem. I am not a techie – I can do the basics on blogs and that’s about it. Even some of what is written above is beyond me.

    Yesterday I was prompted to update my MYSQL database, having been told mine was out of date or words to that effect. I did so and a message came up showing a couple of error messages (I did not record these) but underneath it read something like .. “if you have completed this step and can read this message then this has updated successfully. That is all you need to do”.

    I have about 20 blogs on different subdomains but my main work-from-home blog is the only one which seems to have come up with the same problems shown here .. I believe as a result of the upgrade. When I go to publish a post I cannot – instead it is just saved to drafts and after hitting “publish” a blank screen comes up. Furthermore when I go to delete a post I find I cannot. I went to see what would happen if I went to create a new page … same problem. Just a blank page and then I noticed that all of my Pages had been wiped away (not my posts).

    This is occurring on just the one blog – as I say the others seem to be OK. But it is my central hub of operations, so if anyone can tell me how to fix this problem I would be most grateful. If possible in layman’s terms. It is critical I get this back up and running properly, asap.

    Many thanks

    Dale

Viewing 15 replies - 1 through 15 (of 16 total)
  • The topic ‘cannot publish at all’ is closed to new replies.