Support » Fixing WordPress » Cannot post, Fatal error … taxonomy.php on line 1010

  • danatstadiumvolleyball

    (@danatstadiumvolleyball)


    Fatal error: Cannot use object of type WP_Error as array in /home/stadiumb/public_html/wp-includes/taxonomy.php on line 1010

    I have deactivated all pluggins and tried again and still no luck. Ideas for this non-programmer?

Viewing 13 replies - 1 through 13 (of 13 total)
  • danatstadiumvolleyball

    (@danatstadiumvolleyball)

    Mostly those posts are nonresolved – one did a complete re-install…

    It gives the error – but the page does get listed although the content comes up as 404.

    same thing here… any solutions!?

    Umm… having the same problem here too..

    Problem started after the most recent WP update install. I have multiple WP 2.3.1’s running on multiple sites. Only one gives me this error, but there are too many variables to track. I am flummoxed.

    I get the same error when trying to upload pictures for posts. That’s a bummer. Don’t want to reinstall wp…

    Hello all I am just doing some research into this …
    I know danatstadiumvol has wp e-commerce plugin but does any one else have this plugin installed as I think from all the other posts so far that I have read it come back to this plugin.

    I too are unable to post and feel this is related to Wp e-commerce ??? What do you think??

    Michael

    (@justanewne)

    Also problem when creating new page
    Fatal error: Cannot use object of type WP_Error as array in /home/.torin/globalfriendsnet/pylonltd.com/wp-includes/taxonomy.php on line 1014

    Any work around? is there an old version of the file that is working?
    Thanks

    northsoul

    (@northsoul)

    guys I solved this when I tried to post a page, the page would still post regardless of the error.

    ifixed it by going to options and selecting write and then selecting a default post category other then uncategorized.

    the error went away this was a simple solution offered by the guys wp-commerce…. thanks

    piginzen

    (@piginzen)

    Northsoul-Thanks for the hint. Your suggestion helped me post a Post. But I can’t add a Page. Any idea on how to get pages to work? Thanks so much!

    I am no PHP expert but this seems to have worked and everything is operating as it should. I commented out lines 1012 to 1016 in the taxonomy.php (in the file path listed on the error page) file as follows:

    /* if ( !$id = is_term($term, $taxonomy) )
    $id = wp_insert_term($term, $taxonomy);
    $term_ids[] = $id[‘term_id’];
    $id = $id[‘term_taxonomy_id’];
    $tt_ids[] = $id; */

    I don’t get the error and the page is posted as it should be. I commented it out instead of deleting it just in case there a problems later.

    hi.
    ive solved this problem by removal all records in sql table ‘wp_terms’ and updating ‘terms’ from the blog admin menu ( after updating the in table ‘wp_terms’ ‘slug’ should be readable from phpmyadmin, navicat or any other program for work with mysql )

    btw, before that solution i havent terms in my blog, its surcefully adding but not displayed. now all seems ok

    hope it will help

    Can anyone else tell me if this worked also. Instructions are a little murky. I have same problems and WP ecom install, where are the “terms” you refer to in the admin panel? By “removal all records in sql table ‘wp_terms’, do you mean one at a time in the SQL? — individually delete the entries in the terms table?

    Concerned I might screw up database…

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘Cannot post, Fatal error … taxonomy.php on line 1010’ is closed to new replies.