WordPress.org

Support

Support » How-To and Troubleshooting » cannot open posts from a mobile device

cannot open posts from a mobile device

  • I have been having some problems when viewing my website from a mobile device.

    My website is http://www.sharethepanda.com. I am using the Sampression Lite Theme.

    1. When I go on the website from a mobile device (iPhone) , it takes me to a mobile version of the website http://mobile.sharethepanda.com . The template is distorted and doesn’t look well at all in the mobile version. However, the website is functional and I can open and read the posts.

    2. When I scroll to the bottom of the website and select ‘classic’ view it redirects me to http://www.sharethepanda.com and the mobile version of the website looks brilliant. However, now when I click on my posts to view them (for ex – post on classical music) , it redirects me to http://mobile.sharethepanda.com/classical-music and gives me the message “Looking for a page that cannot be found”.

    I have previously installed WPTouch plugin and it is currently deactivated.
    Also I have WP Super Cache activated.

    If anyone could help me I would very much appreciate it !!!

Viewing 15 replies - 1 through 15 (of 16 total)
  • WPyogi

    @wpyogi

    Forum Moderator

    Is mobile part of your theme? What happens when you use the default twentytwelve theme?

    Thanks WPyogi for the quick reply! The sampression lite theme is advertised to be fully responsive and mobile ready.

    I tried your suggestion and activated the twentytwelve theme. The exact same thing happened. When I first opened the webpage it took me to http://mobile.sharethepanda.com and the template looked distorted however the posts were accessible. Then when I scrolled to the bottom and pressed ‘classical’ view I was redirected to http://sharethepanda.com where the twentytwelve theme looks great but the same message appears when I try to access the posts “Looking for a page that cannot be found”. – it redirects me to http://mobile.sharethepanda.com/post-name.

    In the idea scenario the website would automatically display in the classical view and the posts would be accessible.

    WPyogi

    @wpyogi

    Forum Moderator

    That “mobile” isn’t part of WP – so you must have something else going on – is that a plugin or do you have a mobile option in your hosting?

    Im not sure how to check whether I have a mobile option in my hosting but I did previously install a mobile plugin – WPTouch Mobile http://wordpress.org/plugins/wptouch/ . It is currently deactivated. I may be mistaken but it seems to me that the ‘classical’ view option was available after installing this plugin and remained there once the plugin was deactivated.

    WPyogi

    @wpyogi

    Forum Moderator

    Try deleting that plugin entirely. Make sure you’ve also cleared any caching on your site – SuperCache appears to be active:

    <!-- Dynamic page generated in 0.550 seconds. -->
    <!-- Cached page generated by WP-Super-Cache on 2013-09-04 10:55:12 -->

    I deleted the plugin from the plugin page on WP, then deleted expried and cache from WP super cache settings. Also I have cleared history, cookies and data from my phone before testing but still it is loading the webpage in the mobile view.

    WPyogi

    @wpyogi

    Forum Moderator

    Looks like your site is on GoDaddy – they have a mobile option – have you checked on that?

    I would have to register for a .mobi domain name that I would use for my site (which I don’t have currently – and don’t see why I would need ) . They would create some kind of website with an ‘Instant Mobilizer from dotMobi’ .

    I called godaddy and they told me that something is redirecting the website to that subdomain mobile.sharethepanda.com . They said they could remove it as in “page not found” but they can’t do anything in terms of whats redirecting the website to go there.

    So the problem would then be within wordpress.

    I also have another website hosted through godaddy http://www.mishofilev.com and when opened from a mobile device it doesnt redirect me to the mobile. subdomain.

    Thanks for your patience WPyogi and for the continuous help !!

    esmi

    @esmi

    Forum Moderator

    Have you tried:

    – deactivating all plugins to see if this resolves the problem.

    – switching to the default theme to rule out any theme-specific problems.

    resetting the plugins folder by FTP or PhpMyAdmin. Sometimes, an apparently inactive plugin can still cause problems.

    esmi, I just did all of those things and still the same problem 🙁

    Any suggestions ?

    WPyogi

    @wpyogi

    Forum Moderator

    Looks like you have JetPack on your site – is JP mobile enabled?

    I enabled JP mobile and still the same problem. Before testing I always delete history cookies and data on my phone.

    The website goes to mobile.sharethepanda.com .

    WPyogi

    @wpyogi

    Forum Moderator

    When I scroll to the bottom of the website and select ‘classic’ view it redirects me to http://www.sharethepanda.com and the mobile version of the website looks brilliant.

    Though with twentytwelve you shouldn’t need any mobile version – and I’m guessing that’s true for Sampression Lite too.

    Right now, that is JetPack mobile showing on that view.

    As to the mobile.sharethepanda.com – that’s REALLY quite strange that it’s showing up.

    Can you try (again) to rename the plugins folder – plugins.HOLD and then check again. Also make sure you’ve cleared any caching on your phone.

    Also, just to double-check – I just installed Sampression-Lite on a test site and it does not give me a mobile…. version – so that must be a plugin or something else going on.

    esmi

    @esmi

    Forum Moderator

    There is absolutely nothing in WordPress itself or the 2012 (or 2013) theme that would cause any kind of redirect to a mobile site. To be honest, the whole “separate site for mobiles” approach is a tad old-fashioned. All of the focus these days is on one design (theme) that re-maps itself according to the screen size (aka “responsive design”).

    I’ve just checked your site in my iPad and I’m not being redirected to http://mobile.sharethepanda.com/ Are you you still being redirected on your iPhone?

    WPyogi

    @wpyogi

    Forum Moderator

    I just checked on my iPad – not redirected – but on my iPhone it IS redirecting – and that was after clearing my cache on the phone…

Viewing 15 replies - 1 through 15 (of 16 total)
  • The topic ‘cannot open posts from a mobile device’ is closed to new replies.
Skip to toolbar