Support » Installing WordPress » Cannot open install.php

  • I’ve downloaded WordPress and following the handy guide for installing it.

    Having installed PHP 5.3.6, using the wizard, and, selected IIS CGI as my web server of choice, I am trying to open install.php as indicated on the installation guide.

    However, the web browser (in my case Mozilla FF) does not seem to be doing anything useful beyond prompting me for the application to use to run install.php (see screenshot.

Viewing 12 replies - 1 through 12 (of 12 total)
  • you need to put the wordpress files into the web server’s root directory, then navigate to the address with you browser (probably http://localhost/wp-admin/install.php).

    you’ll also need MySQL.

    Sure, but why does the window keep popping up? I tried installing WordPress through Web Platform after installing FastCGI (this link), which includes WordPress and MySQL, however, the wizard is still stuck on the cancelling after taking ages (more than 2 hours) to finish off the installation on WinXP SP3.

    I guess I have to install WordPress and mySQL from scratch now as individual programs.

    Do you need to carry out additional configuration to run PHP scripts?

    I tried repeating the problem and, got the same issue. I even noted that I cannot logon to mySQL using the root password that I originally assigned within the installer program.

    Would you kindly review my notes for installing WordPress?

    1. Unpack and copy wordpress to C:\Inetpub\wwwroot\wordpress, and, configure the IIS 5.1 directory.
    2. Install mySQL 5 community edition , and optionally, a tool such as SQL Yog.
    3. ???

    I think I should have PHP installed as well, which I do, and, I also have Adobe Dreamweaver which finds no formatting problem with the .php files, however, I am not sure how to get wordpress up and running yet.

    the window keeps popping up because you’re trying to open the file by double clicking on it. you’re supposed to navigate to the local web server address in your browser, then IIS will run the PHP script and serve up the webpage.

    it might be easier if you used WAMP.

    or microsoft’s web matrix

    I copies the wordpress files within C:\Inetpub\wwwroot\wordpress, after having installed FastCGI, however when I try to navigate to, the browsers (Mozilla/Google Chrome/IE8) prompt me to download the file, because that seems to be the default behaviour.

    Nevertheless, I could not find WAMP any easier because after the installation is complete I found no way of running PHP scripts; sorry I’m a newbie.
    Microsoft’s web matrix stalls while installing mySQL.

    I also tried installing mySQL on its own, however, the installation wizard fails when it tries to start the mysql service, with the following error:
    Cannot create Windows service for mySQL.error:0
    I am running WinXP SP3.

    it looks like PHP isn’t installed properly or it isn’t running. I don’t actually use WAMP so I can’t help you further with this, sorry.

    you might want to try uninstalling everything first then starting again.

    I tried installing a new virtual machine, running on VMWare Player, and, installing Windows Server 2008, which uses IIS 7.0.

    I was successful in installing PHP 5.x, and, copied the wordpress files over to a sub-directory where IIS can reach it, however, I got to a page, where WordPress installation (browsing to http://localhost/wordpress/wp-admin/setup-config.php?step=1), where I am being asked for the logon credentials to MYSQL, which are being rejected, even though I am using the same logon credentials to logon to mySQL through the command line. This means that WordPress is not “finding” the database, and, as I originally suspected the problem originates from mySQL database.

    Has anyone encountered this problem?

    Well, now I worked around the mySQL logon problem. I had a look on Google, and, other users have had an issue with the default logon credentials for mySQL, and I had installed two versions of mySQL, one manually, and, another one – that included the phantom (unknown) logon credentials, was included by the installation of the Microsoft Web Platform.

    However, now I’m stuck with trying to complete the wordpress installation, since, having copied the automatically generated wp-admin.php within my virtual directory on IIS (..inetpub\wordpress\), the installation wizard (wp-admin\install.php) seems to be going around in circles as it is not finding the database that I have created through mySQL.

    I think that there is a permissions problem that needs to be resolved to allow .PHP scripts to write within inetpub, even though unexpected since I am logged on as an Administrator. Any idea how to go about it?

    have you actually created the database? being able to logon to mysql through the command line doesn’t mean you actually have a database created.

    you can use the show databases command to check.

    Yes of course

    I think somehow the installer is not connecting to the appropriate mysql service, I will have a second shot at the installation, and see how it goes.

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘Cannot open install.php’ is closed to new replies.