Support » Plugins and Hacks » [Resolved] Cannot modify settings

[Resolved] Cannot modify settings

Viewing 12 replies - 1 through 12 (of 12 total)
  • Plugin Author Paul G.



    What version of the plugin are you using?

    Would you have any restriction on cookies at all? On the latest version of the plugin I cannot replicate this unfortunately.

    One option is to private provide me with access to your site so I can debug it.


    I am using the last version. Now on one site i have acces on one site but not on the other. Is there a way to reset? So that I can start fresh? I have tryed to drop the tabels from the database, and then reinstal but still nothing. And the tabels did not reapear. The firewall seems to be working, I receive emails that tell me that he is blocking some adresses but is anoing that i cannot modify a thing, although recognise my key.
    Thank you for your help

    Plugin Author Paul G.


    You can forcefully turn off all the features.

    See: https://icontrolwp.freshdesk.com/support/solutions/articles/3000000959

    In this way you’ll turn off everything and then you’ll be able to build it up again. If it’s still not creating your db tables, I’ll have to think of a way to fix that automatically.

    Let me know how you get on with turning it all off.


    After turnoff functions, everythig is now turn off except the anoying key. And now the firewall does not work and I cannot switch it back becouse I get something that says You have insuficient rights to acces this page for xxxxxx.com/wp-admin/admin.php?page=icwp-wpsf-firewall
    and the same message for any setings I try to acces.

    I put a forceOn in plugin directory and now I can see in plugin dashboard that is back actvie even thou I cannot acces any setings.

    Plugin Author Paul G.


    Okay… will you be able to give me access to the site?

    I’ll need admin and FTP access. If so, please email it to support@icontrolwp.com




    Forum Moderator

    @paul G.: Sorry but that’s not cool and really goes too far. Accessing a user’s system like this makes you responsible for that user’s system. If you make changes and something breaks later on as a result, then it is your fault.

    Get information, ask for log data, have the user contact you & seek copies of the PHP files. Look but don’t touch. If your code is the problem, then produce a fix and post it here. If the theme or another plugin is at fault, then inform the user, suggest a fix, offer to contact the other developer and/or update your FAQ.

    But do not try to make changes to the user’s files in this way. That’s really going too far outside of your area of responsibility.

    Plugin Author Paul G.


    This isn’t the first time I’ve asked for it, received it, and fixed the problem.

    Sorry, but I don’t agree… there’s nothing uncool about it.

    Seeing the environment that’s causing the problem if I can’t replicate it is kinda critical to posting a fix. If you look through my support for the past couple of years on all my plugins you’ll see I do all that you suggest.

    And am I responsible? No. I wouldn’t log in unless they agreed to that. I understand your points made. But is it “uncool”, no.

    I can’t replicate this issue. So by your suggested position, it’s not to be fixed.


    Plugin Author Paul G.


    @sebastost I can’t solve your problem, but I fixed the issue where ‘forceOff’ wasn’t turning off the admin restriction. That should help you get back into the plugin at least, though it may not solve the admin access restriction not accepting your password.

    I hope it helps.

    Sorry for the delay. I will try to offer you access in a day or two. For the moment the plugin do his job 🙂
    ForceOff did not help, is like something remain stuck somewhere. My pass is accepted because I see the dashboard and the fact that firewall is on or off, but i cannot access the settings, when I try I am redirected to a page where I dont have rights. And if I try to unset the autorization and the rest (the part where you can put on or off firewall etc.) after I press save I am back to “enter access key”
    We will continue the discussion in a day or two when I have the time to offer you access.
    Thank you very much for support and also for the plugin

    Ok Paul, problem solved with the last update. I deleted the plugin via ftp, reinstaled the new version, again “enter access key”, created force off and the everything is perfect.
    Thank you again very very much.

    I consider the problem solved

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘[Resolved] Cannot modify settings’ is closed to new replies.