WordPress.org

Support

Support » Installation » [Resolved] Cannot modify header information, wp-config.php:1 has no blanks

[Resolved] Cannot modify header information, wp-config.php:1 has no blanks

Viewing 11 replies - 1 through 11 (of 11 total)
  • vpsdiscussions
    Member

    @vpsdiscussions

    Please check in wp-login.php file and see if there are no malicious codes inserted. It may be possible that your blog hacked by someone.

    vitalichka
    Participant

    @vitalichka

    Looks good, nothing out of the ordinary.
    What else could it be?

    WPpremium
    Member

    @wppremium

    If you have not modified any default WordPress files, download the wordpress version which you have installed and make the necessary changes in your wp-config.php file. Now, upload all files in your domain’s space and see if it helps.

    Also, your blog is working fine at my end. Clear your cache/cookies and then try to access it from your end.

    vitalichka
    Participant

    @vitalichka

    Thanks for your responses. I’m sure files have been changed being that I have a few plugins running but its interesting because I have an identical site on wmcbba.freehostia.com identical site and it works fine. Also my site worked fine yesterday and not this morning, I’m wondering if could have been the db backup I did last night. Also its not the cookies or cache I have tried clearing them and still the same. I have printed out the stock files and my files and all looks well. Its interesting being that I always have these peoblems with wp but tend to fix it somehow and its never been the “blank spaces”, etc.
    Anything else u think? Does the code above look good? I noticed there was no end tags at the end. I added them but made no difference also the sample file doesn’t include end tags either.
    Please help.

    vitalichka
    Participant

    @vitalichka

    Also forgot to mention that the front end does work fine it the back end I can’t get into. Try loging in or registering.

    esmi
    Forum Moderator

    @esmi

    Try resetting the plugins folder by FTP or phpMyAdmin

    vitalichka
    Participant

    @vitalichka

    How would you do this and wouldn’t they need to be deactivated?
    Thank you, were getting somewhere.

    vitalichka
    Participant

    @vitalichka

    Oops sorry about that you provided a link. So sorry. I am at work and am using a phone to access.

    vitalichka
    Participant

    @vitalichka

    Ok so I reset the plugins folder via FTP and this changed nothing. Don’t know where to go with this now. Anything else you think it could be?

    vitalichka
    Participant

    @vitalichka

    I think I figured it out. I got home and loaded a backed up copy of wp-config.php I had saved yesterday. The only difference between the two was that there was a mention of wp-cache.

    /** Sets up WordPress vars and included files. */
    require_once(ABSPATH . 'wp-settings.php');
    
    define('WP_CACHE', true);
    ?>

    where as the original copy that works and is currently on the site looks like this.

    /** Sets up WordPress vars and included files. */
    require_once(ABSPATH . 'wp-settings.php');

    Hope this helps. Once I logged it, I could see that WP Super Cache was deactivated but it seems like there was still code referring to it in the file and being that this was the only difference, must have been the culprit.

    Even renaming the plugins folder to plugins.hold and creating a new and empty one didn’t do anything.

    Thanks for all of your input and help. I hope this helps someone else now who may be encountering similar problems. There were not blank lines or spaces or anything like that although this can be the problem sometimes, as I have seen and experienced myself many times before.

    Thanks again.

    coffee3k
    Member

    @coffee3k

    Yes! WP Super Cache was the problem. Thanks.
    I also have this line, once I quote it out everything went back to normal.
    define('WP_CACHE', true); //Added by WP-Cache Manager
    Thank you vitalichka.
    Cheers!

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘[Resolved] Cannot modify header information, wp-config.php:1 has no blanks’ is closed to new replies.