WordPress.org

Support

Support » How-To and Troubleshooting » [Resolved] Cannot Modify Header information – when making a post, editing page info, etc

[Resolved] Cannot Modify Header information – when making a post, editing page info, etc

  • I have that awesome header error that a lot of people seem to get.
    I have checked options.php, pluggable.php, functions.php, wp-config for any extra spaces using dreamweaver and believe me, there are none.

    This issue was not there a few weeks ago, and just arose after no significant changes to the site.

    Have tried deavtivated all plugins- no change. (it actually shows up even when I try to do this)

    Odd part about it – when making a new post and hitting publish the error shows up, but when I refresh the post was made. It shows up on my site, but when I try to actually view the post online it takes me to a 404 page. The excerpt does appear though.

    Here is my specific error:
    Warning: Cannot modify header information - headers already sent by (output started at /services7/webpages/e/-/e-ternity.ca/public/wp-content/themes/qresponsive/options.php:1) in /services7/webpages/e/-/e-ternity.ca/public/wp-includes/pluggable.php on line 881

    Any help would be so appreciated you have no idea.. I’ve been reading similar forums for a few hours now with no luck..

Viewing 3 replies - 1 through 3 (of 3 total)
  • What about with the 2011 theme?

    nashproductions

    @nashproductions

    Hey Andrew – we ended up switching to a new host to ensure proper backups when trouble-shooting this issue. Not sure if you’re still up for paying attention to this post, BUT the site DOES work with the 2011 theme active.

    I’ve gathered the issue is coming from the functions.php file somewhere as when I remove it everything saves okay.

    Here’s my functions.php file for a gander.

    nashproductions

    @nashproductions

    Update : Problem SOLVED!

    The issue was was options.php and it being re-saved as a unicode UT-8 at some point. I work on a mac so had to resave as Western (Windows Lating 1), the equivalent of ANSI.

    Can’t believe the ridiculousness!

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘[Resolved] Cannot Modify Header information – when making a post, editing page info, etc’ is closed to new replies.
Skip to toolbar