WordPress.org

Ready to get started?Download WordPress

Forums

No spaces... but, still a problem (15 posts)

  1. responso
    Member
    Posted 6 years ago #

    When i am up to put my login and password the ...

    "Warning: Cannot modify header information - headers already sent by (output started at /wp-config.php:1) in /wp-login.php on line 202

    Warning: Cannot modify header information - headers already sent by (output started at /wp-config.php:1) in /wp-login.php on line 214"

    ... error apears. I am able to put log and pass but after that i get that error...

    "Warning: Cannot modify header information - headers already sent by (output started at /wp-config.php:1) in /wp-login.php on line 202

    Warning: Cannot modify header information - headers already sent by (output started at /wp-config.php:1) in /wp-login.php on line 214

    Warning: Cannot modify header information - headers already sent by (output started at /wp-config.php:1) in /wp-includes/pluggable.php on line 557

    Warning: Cannot modify header information - headers already sent by (output started at /wp-config.php:1) in /wp-includes/pluggable.php on line 694"

    I have no idea what that means. Please help. What i should do?

    I have no wrong spaces in wp-config.php!

  2. designsimply
    Member
    Posted 6 years ago #

    Can you verify that your server meets the minimum requirements for WordPress? Have you been able to login in the past, or is this a brand new install? Have you edited any files recently?

  3. responso
    Member
    Posted 6 years ago #

    It's brand new install. I have edited wp-config.php only and yes my server meets minimum requirements.

  4. designsimply
    Member
    Posted 6 years ago #

    Can you check your wp-config.php one more time and make sure you are using a plain text editor such as TextEdit **in plain text format mode** on Mac, Notepad on PC, or vi on linux?

    Important, you must edit wp-config.php in plain text. TextEdit on Mac uses rich text formatting by default. You can change it by clicking Format > Make Plain Text.

  5. responso
    Member
    Posted 6 years ago #

    I'm sure used Notepad.exe. I'm PC user.

  6. designsimply
    Member
    Posted 6 years ago #

    Hmm. Maybe try deleting and re-uploading the wp-admin and wp-include folders.

    Also, check out this similar post for more details:
    [resolved] trouble upgrading from 2.5 to 2.5.1

  7. Dee_Cee
    Member
    Posted 6 years ago #

    I'm having the same issues.. My login screen (before even entering my login details) has this error:

    Warning: Header may not contain more than a single header, new line detected. in /home/hookersd/public_html/ArePeopleReal and Broken Hookers Blog/wp-login.php on line 216

    I have removed the spaces, can anybody help?

    I am first time user, first install, using a Mac and editing in Dreamweaver.. I'm new to PHP and MySQL so please don't bite my head off! I have tried searching but I can't seem to fix it!!

    Thanks,

    Darren

    (Note - You can see the issue here: http://brokenhookers.com/ArePeopleReal%20and%20Broken%20Hookers%20Blog/wp-login.php)

  8. Dee_Cee
    Member
    Posted 6 years ago #

    I started again/reinstalled everything.. and now it works.

    Maybe try that!

  9. responso
    Member
    Posted 6 years ago #

    Reinstall did not helped in my case >_<
    http://responso.pl/wp-login.php

  10. responso
    Member
    Posted 6 years ago #

    Reinstallation still does not fix anything! Please help me!

  11. Ivovic
    Member
    Posted 6 years ago #

    responso, please start with a NEW freshly downloaded wordpress wp-config.php file.

    Edit it with Wordpad, NOT notepad or anything else, then upload.

    You DEFINITELY have some kind of (invisible?) characters in your file. Reinstalling will not help you, only using a fresh file.

  12. responso
    Member
    Posted 6 years ago #

    I have been editing wp-config.php with Wordpad, Notepad and Dreamweaver. There is no spaces, etc.

  13. Ivovic
    Member
    Posted 6 years ago #

    I'm telling you, start with a fresh file.

    The first sign of insanity is doing the same thing repeatedly, but expecting a different result. Don't do what you've been doing so far.

    1) fresh file (download it again)
    2) edit with wordpad
    3) save
    4) upload by FTP (no other method)

    notepad can suffer from encoding issues, so don't even bring your file close to notepad or anything else.

  14. jockel
    Member
    Posted 6 years ago #

    Hi,

    it does not seem to be a problem of users damaging the config.php file.
    Probably the "wp-config-sample.php" at least in the german zip file
    (ad of today) is buggy. I saw the same errors, already with the install call.
    I was using notepad++, uedit and pspad for testing/editing.
    To solve it, I copied the entire contents of "wp-config-sample.php"(ctrl-A/paste)
    into a new file, edited accordingly, saved as "wp-config.php" and uploaded. Everything went fine then!

  15. joshfraz
    Member
    Posted 5 years ago #

    I had this problem too. It turned out that I had an extra space at the end of my siteurl option. Once I removed the space it worked fine.

Topic Closed

This topic has been closed to new replies.

About this Topic