WordPress.org

Support

Support » How-To and Troubleshooting » Cannot modify header information – headers already sent

Cannot modify header information – headers already sent

  • when I try to unaprove comments I get this warning:

    Warning: Cannot modify header information - headers already sent by (output started at /public_html/wp-admin/admin-header.php:8) in /public_html/wp-admin/post.php on line 569

    anyone know what to do?

Viewing 15 replies - 1 through 15 (of 22 total)
  • thanks a lot. cheers!

    so far…that didn’t work. I checked the files that it wanted, and edited them…still getting that same error.

    I took out this line on post.php in the admin folder

    require_once(‘./admin-header.php’);

    that was line 548, under the unaproove section. the aproove section did not have that line, so I took it out under the unaproove section and it’s working fine…anyone know what that line does, or if there will be a problem without it?

    Moderator James Huff

    @macmanx

    Support Team Rep.

    Umm… put that line back. You’ll need to call admin-header.php for the proper operation of your admin interface. As quoted in the error, the problem is in admin-header.php on line 8.

    Hmmm… I don’t think it’s a smart idea to take out lines (especially when they say “require”) from the core files.
    Stick to the finding the white spaces! What text editor are you using?


    case 'unapprovecomment':

    require_once('./admin-header.php');

    check_admin_referer();

    was the line…and after I removed it then it was fine…so, I should look in the file on line 8 then, ok.

    I put that line back…and I can not find any problems with admin-header.php and on line 8 is some html…

    <title><?php bloginfo(‘name’) ?> › <?php echo $title; ?> — WordPress</title>

    that is the line…

    notepad is what I am using

    all of my files for whatever reason don’t have line breaks…instead they have an unknown BLOCK char…that I have to go through and replace all of them with a crlf…not sure why that either…

    Try TextPad or any other editor that understands about Unix-style line breaks. If you search here, you’ll find plenty of suggestions for good text editors, many of them free. Notepad is really not up to the job….

    Moderator James Huff

    @macmanx

    Support Team Rep.

    Download WordPress again, delete the admin-header.php file off of your server and upload a new copy from the fresh download.

    For a good text editor, see this list:

    http://codex.wordpress.org/Glossary#Text_editor

    I tried reinstalling the whole thing…and it is still saying the same error. I have looked and corrected tons of whitespace in files and things are still being borked up…any other thoughts?

    Moderator James Huff

    @macmanx

    Support Team Rep.

    What FTP app are you using?

    filezilla

Viewing 15 replies - 1 through 15 (of 22 total)
  • The topic ‘Cannot modify header information – headers already sent’ is closed to new replies.