Support » Fixing WordPress » Cannot Modify Header error in rss feed

  • Resolved TheFigster


    I keep getting this error when trying to see my feed:
    Warning: Cannot modify header information - headers already sent by (output started at /home/jimnewt/public_html/jimsblog/wp-blog-header.php:2) in /home/jimnewt/public_html/jimsblog/wp-includes/feed-rss2.php on line 2

    I also do not like the look of the feed. Having abandoned my search for truth, I am now looking for a good fantasy. Sat, 30 Jun 2007 19:39:13 +0000 en Sun, 24 Jun 2007 19:18:03 +0000 TheFigster Sun, 24 Jun 2007 15:12:11 +0000 TheFigster Sun, 24 Jun 2007 15:06:49 +0000 TheFigster
    Nothing but URLS I do not think that wordpress feeds were meant to look like this. I have tried my default theme and have the same results, I have removed all plugins, with same results. I remove the header call in my feed-rss2.php: header('Content-type: text/xml; charset=' . get_option('blog_charset'), true); I will sometimes get an error, or I will see the feed as it looks above.
    Do I need to rewrite the header call? Is there a way for the RSS to show Title, description, content.. something more than it does?

    Link to my blog.


Viewing 5 replies - 1 through 5 (of 5 total)
  • Any Ideas anyone?..
    Your help is appreciated


    Next time, how about a link to your feed please? 😉

    The header issue is usually caused by empty spaces to lines after the closing ?> mark with your config.php file. Please check that and make sure the mark is the last thing in your file.

    Part of the issue may also be your urls. While you’re telling folks that is the URL (by the way, the ‘www’ in there is incorrect and chances are you’ll be ignored by search engines and about 30% of the net who can’t follow such a link) your blog thinks it’s at You probably should pick one or the other and stick with it.

    I would put the header call back in there. It’s there for a reason.

    Not sure how you’re looking at your feed. I see the text of your feed find and not just the links. example.

    Hope thi shelps,

    Thank you for your input, I have my settings in admin to read the url as yet it still produces the other links. I checked the wp-config.php and there isn’t any blank space after the last ?> I have also tried deactivating all plug-ins, and changing themes.
    I have another blog on the same server where the feed looks great.
    I am starting to think I may need to completely uninstall WP and reinstall it at this point.
    Oh and the feed did start looking better when I selected show whole post in the admin settings. Before it looked like the example in my first post.
    I do appreciate your help, gave me something to try…

    Any other suggestions before I uninstall?


    I un-installed and re-installed and was able to correct the problem. Even though plug-ins were disabled I think it was a plug-in problem.. just do not know which one.

    Thanks for the help.


    Update: after reinstalling and replacing all my blog entries I started reinstalling the plug-ins one at a time and checked the feed with each one and discovered that the WP-Polls created a header error I had a header error the first time I attempted to use this plug in and fixed it by following the authors recommendation and altering the header call in that plug in. I re-uploaded with that same fix and messed up the feed, however going back to the original plug-in fixed the problem.

    At any rate if you run into this problem, and have the WP-Polls plug in, try uninstalling that plug-in.


Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Cannot Modify Header error in rss feed’ is closed to new replies.