WordPress.org

Forums

[resolved] [closed] Cannot login to wp-admin (14 posts)

  1. peter1
    Member
    Posted 4 years ago #

    Hi all,

    I have a bunch of wordpress sites. Today I find that for most of them I cannot login.

    For each one that I cannot login to the login.php page won't load properly. It loads without formatting with the login fields right on the left, and nothing much else.

    When I try to login I get the standard oops error page for wp-admin.

    This is the same across quite a few sites.

    But I also have some other sites where the login.php loads fine, and for each of those I've been able to login fine.

    It's not a computer problem as I've tried it on 2 different computers.

    Anyone got any ideas? I'm totally stumped.
    Thanks
    Peter

  2. peter1
    Member
    Posted 4 years ago #

    Sorry, forgot to mention, all the sites themselves are there, no problems with the sites, just the login

  3. Tara
    Volunteer Moderator
    Posted 4 years ago #

    Have you tried:

    1. deactivating all plugins to see if this resolves the problem? If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    2. switching to the default theme to rule out any theme-specific problems?

    3. resetting the plugins folder by FTP or phpMyAdmin? Sometimes, an apparently inactive plugin can still cause problems. see instructions here: http://codex.wordpress.org/FAQ_Troubleshooting#How_to_deactivate_all_plugins_when_not_able_to_access_the_administrative_menus.3F

    4. re-uploading the wp-admin and wp-includes folders from a fresh download of WordPress?

  4. peter1
    Member
    Posted 4 years ago #

    Thanks for that, strangly when I came back here to read this this forum has lost all of it's formatting too. I hope this posts.

    I don't know whether it's a plugins thing, as some sites are working and these have the same plugins as those that are not. But I'll give that a go.

  5. peter1
    Member
    Posted 4 years ago #

    No it's not plugins. I have tried the ftp method and I have changed to an empty plugins folder and still have the same problem.

    How do I change themes if I cannot login? And is the theme likely, I have the same theme on both sites that are working and those that are not.

    Thanks for the help
    Peter

  6. James Huff
    Volunteer Moderator
    Posted 4 years ago #

    How do I change themes if I cannot login?

    Access your server via FTP or SFTP, navigate to /wp-content/themes/ and rename the directory of your currently active theme. This will force the Default theme (WordPress 1.5 - 2.9.2) or the Twenty Ten theme (WordPress 3.0 and higher) to activate and hopefully rule-out a theme-specific issue.

  7. peter1
    Member
    Posted 4 years ago #

    Thanks, tried that. When I do that I get a blank white page for my site so it isn't loading the default theme I assume, when I rename the theme back to normal the site comes back with my theme.

    Not sure if that helps or not.

    Interestingly I am also finding that for most of the sites causing problems I am unable to login to ftp. But for some I can.

    Thanks

  8. James Huff
    Volunteer Moderator
    Posted 4 years ago #

    In that case, you could be having some server problems. Have you contacted your hosting provider yet?

  9. peter1
    Member
    Posted 4 years ago #

    This is occuring over a number of sites on 3 different servers in 2 different countries and 3 different hosting providers.

  10. James Huff
    Volunteer Moderator
    Posted 4 years ago #

    Did this all happen at the same time? Can think of what these sites have in common?

  11. peter1
    Member
    Posted 4 years ago #

    Good questions. I noticed it this morning and all of them that didn't work didn't work this morning, but did work within the last few days.

    But as far as differences go no there isn't much at all I can think of. For example I built about 8 sites, all at the same time, all in the same niche, all with the same theme and plugins and all using the current version.

    Of these 2 don't work and the others do.

    Got me totally tossed, I have no idea what is going on.

    And strange as well that about half the time I come back to this forum to read answers this forum too has lost it's formatting, and other times is hasn't.

    That's why I tried it on another computer as I thought maybe it was a computer problem, but on my other computer it's the same.

    Many of the sites that won't work won't load the login.php page correctly. But then there is a few that will load that page correctly and still can't login.

    Hmmmm. Totally stuck with this.

  12. James Huff
    Volunteer Moderator
    Posted 4 years ago #

    Maybe it's a problem with your home network connection? I've been on these forums quite a bit today and haven't noticed any problems.

  13. peter1
    Member
    Posted 4 years ago #

    Ok, got it. First thanks to all for the help.

    James prompted me into ringing my isp. Found what it was.

    I have security on my sites in the form of an htaccess direct to allow login only from my ip, which is static.

    But totally without telling me my isp changed my ip address last night. Nice of them to do so without notifying anyone.

    So that was it. All working now.

    What the formatting problems were I don't know, I am still getting problems with the formatting of this site, but I'll put it down to gremlins. But I can now login to my sites.

    Thanks again for the help all, nice to know there's someone out there to talk to when things go wrong.

    Peter

  14. James Huff
    Volunteer Moderator
    Posted 4 years ago #

    You're welcome, I'm glad they were able to help!

Topic Closed

This topic has been closed to new replies.

About this Topic