Support » Fixing WordPress » Cannot login to subdomain's wp-admin

  • geekyramon

    (@geekyramon)


    I have installed wordpress 3.6 on my site and activated Multisite. I chose to configure the site to use subdomains instead of subfolders. I have modified the .htaccess file to have the following:

    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ – [L]

    # add a trailing slash to /wp-admin
    RewriteRule ^wp-admin$ wp-admin/ [R=301,L]

    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ – [L]
    RewriteRule ^(wp-(content|admin|includes).*) $1 [L]
    RewriteRule ^(.*\.php)$ $1 [L]
    RewriteRule . index.php [L]

    I also added this to the wp-config.php file:
    /* Multisite */
    define( ‘WP_ALLOW_MULTISITE’, true );

    define(‘MULTISITE’, true);
    define(‘SUBDOMAIN_INSTALL’, true);
    define(‘DOMAIN_CURRENT_SITE’, ‘geekinsights.com’);
    define(‘PATH_CURRENT_SITE’, ‘/’);
    define(‘SITE_ID_CURRENT_SITE’, 1);
    define(‘BLOG_ID_CURRENT_SITE’, 1);

    The problem is i cannot go into my subdomain’s wp-admin. Whenever I do I get a 404 error despite the fact that I can login at the main domain’s wp-admin. Is there something else I need to do that I may have forgotten? Any advice on how I could fix this?

Viewing 2 replies - 1 through 2 (of 2 total)
  • geekyramon

    (@geekyramon)

    Update:

    Ok, I just noticed that there’s nothing in the subdomain’s folder except an empty cgi-bin folder. The 404 is being generated because there is no index.php in my subdomain’s folder.

    Does this mean I have to install wordpress to my subdomain’s folder? Can’t i just populate this subdomain with my current wordpress installed from the top level domain?

    geekyramon

    (@geekyramon)

    Update 2:

    Sigh. I got it to work… but there’s still a small issue.

    But first, here are the steps I took to go into the wp-admin area of my subdomain.

    1. Deleted subdomain from within wordpress.
    2. Deleted subdomain from within CPanel
    3. Added subdomain from within wordpress.

    And it works. I can now go into my subdomain’s dashboard and customize everything.

    The only problem is the subdomain is not being listed under the dropdown menu when I hover my mouse on “My Sites”. The only things being shown are “Network Admin” and my TLD site.

    This seems like a minor issue but I’m afraid it might cause havoc later down the road. Can anyone give some pointers on how to fix this?

    (This monologue is getting tiresome. Sigh.)

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Cannot login to subdomain's wp-admin’ is closed to new replies.