Cannot login to second website on multi-site installation (3 posts)

  1. Gabriel5231
    Posted 3 years ago #


    I've recently been trying to set up multi-site multi-domains for my WordPress installation, so that I can have multiple sites with separate domains. I believe the Domain DNS is setup correctly because http://www.saporibistro.co.uk now links to the correct WordPress site. However, I cannot login to Sapori Bistro. When I try to login with the correct details, it just refreshes the page. When I try to login with (purposefully) incorrect details, it gives me two errors:
    ERROR: Invalid username. Lost your password?
    ERROR: Cookies are blocked or not supported by your browser. You must enable cookies to use WordPress.

    By the way, I do have cookies enabled.

    Its been puzzling me for weeks! I can login to my original WordPress site fine. My sites are hosted on an Amazon EC2 instance using BitNami-3.3.2-0 on Ubuntu 12.04. I've been using WordPress MU Domain Mapping to map the Sapori Bistro domain to my WordPress site.

    Does anyone know what might be the problem?



  2. pmathews
    Posted 3 years ago #

    Same issue here, original site is working perfectly both on the front-end and on the back-end, and while the second site front-end displays properly, I cannot login to the back-end (admin dashboard) for the second site. Any ideas?

  3. pmathews
    Posted 3 years ago #

    I have found a possible solution (this worked for me): when you create a sub-domain as a new site, then repoint to a parked domain, you lose the ability to update your site via the dashboard (that was my issue). When I repoint the site to the subdomain, the management console appears again and works fine. In hindsight, it seems like a no-brainer, but it cost me 4 hours of before I realized it was something simple.

    Created a site as a subdomain -> http://site2.site1.com

    Repointed to -> http://site2.com (console doesn't work)

    So this raises a different issue: When using Multi-site, creating sites under subdomains is very straight-forward, but creating sites under separate parked domains is not clear to me. I'm sure there's a way to do it. Any ideas?

    Thanks... Paul

Topic Closed

This topic has been closed to new replies.

About this Topic