Support » Plugin: iThemes Security (formerly Better WP Security) » Cannot Login to Admin and Get Banned immediately

  • Hi, After setting up WP Security and logged out of admin, I can longer access admin. I type ” http://domain.com/wp-admin” and get error message “not found”. When I try to access website “http://domain.com/” I get “Error”. When I check the database through the cPanel, I find my IP address under lockout list. I remove IP address from list and try again to access “http://domain.com/wp-admin”, I get same error “not found” and my IP address is banned.

    I am not sure which setting causes this. But I need to change it from the cPanel. How can I do that? How can I access Better WP Security Settings through the cPanel? Please help!!!

    http://wordpress.org/extend/plugins/better-wp-security/

Viewing 4 replies - 1 through 4 (of 4 total)
  • Handoko

    (@handoko-zhang)

    Thank you Handoko,

    I have added “#” at the beginning of this line:
    “# RewriteRule ^.*wp-admin/?|^.*wp-login\.php /not_found [R,L]”

    Is the plugin still going to be able to ban user who try to intrude?

    Handoko

    (@handoko-zhang)

    Yes, it still will ban users who type wrong password or username. Adding the # above is only disabling hide login feature. It means your login url is now wp-login.php again, also you can access your backend by simply type …/wp-admin.

    Once you gain access to your backend (admin area) you should:

    – Set new login slug (goto menu > Security > Hide Backend > Login Slug).

    – If you don’t want to change the default login, you should disable it, goto menu > Security > Hide Backend > disable the Enable Hide Backend.

    Note:
    If you enable the Hide Backend feature, you will not able to access your admin area by typing domain.com/wp-admin. You will have login to access your admin area by using the new login slug. I hope you understand.

    it works beautifully, thank you 🙂

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Cannot Login to Admin and Get Banned immediately’ is closed to new replies.