• Resolved neotechnomad

    (@neotechnomad)


    I cannot login to any of the sites I admin since the plugin update to 1.8.6.
    I have to rename the Sucuri plugin via FTP and then I am allowed to login – then rename the plugin via FTP back again.
    I can navigate the Dashboard, but when I logout, I cannot log back in.

    Please fix this.

Viewing 15 replies - 16 through 30 (of 46 total)
  • For me, the solution I posted worked on all my sites.
    I’m baffled as to why it hasn’t worked for others.

    I have reset this thread to ‘Not Resolved’ so that the developer knows there is still an issue.

    Note:

    Deleting the plugin folder via FTP or File Manager in cPanel will not work.
    You have to delete the plugin through the WP admin dashboard Plugins section – then it deletes all the data associated with the plugin.
    If you delete through FTP or cPanel, all the data (settings, etc.) remain in the database, so the plugin remains faulty.

    So…

    Uninstall the plugin through the WP admin dashboard Plugins section and optimize your database if you have an optimizing plugin.
    Reinstall the plugin through the WP admin plugins section, get a new API Key and UNCHECK the box for that option in the API Request pop-up window, and then reconfigure plugin.

    MAKE SURE that SUCURI > Settings > General > IP Address Discoverer and Reverse Proxy are disabled.

    The “IP Address Discoverer” is enabled by default when you are requested to obtain the API Key – again… UNCHECK the box for that option in the API Request pop-up window and it will be disabled.
    This “IP Address Discoverer” seems to be the major issue.

    I am hitting this same issue today after updating to the latest version. I can’t login no matter what I do, until I disable this plugin. This is a critical issue for us so hopefully it can be resolved soon.

    Uninstall the plugin through the WP admin dashboard Plugins section
    How did you do this when no pages in wp-admin will load? Deleting via FTP was the only way I could get the site working again.

    Edit: never mind, just re-read your comments – you renamed the sucuri-scanner folder via FTP so the plugin would deactivate, then uninstalled it via the (now functional) Plugins screen, correct? I’ll give that a shot!

    • This reply was modified 10 months, 4 weeks ago by  . Reason: Added fix

    @linnalexandra Yes… leave the ftp open after renaming the plugin (…an ‘x’ behind the name is sufficient), login but do not go anywhere or do anything.
    Go back to ftp and rename the plugin back again – then go into plugins section and delete plugin.

    That worked, thank you! Just to clarify for others, here are the steps I followed that seem to have fixed it:

    1. Rename plugin folder via FTP (changed to xsucuri-scanner)
    2. Login to WP admin, visit Plugins page to confirm Sucuri plugin is deactivated
    3. Rename plugin folder via FTP (back to sucuri-scanner) – this probably isn’t necessary but just in case
    4. Delete Sucuri plugin via Plugins page
    5. Go to phpMyAdmin and optimize database (if you don’t have an optimization plugin as @neotechnomad suggested)
    6. Go to Add Plugins and reinstall Sucuri plugin, activate it and visit Settings page to disable IP Address Discoverer and Reverse Proxy (although at this point the site seemed to be functioning normally, I didn’t want to risk it)

    With all that said, I’d rather not go through these steps on every site I manage. Hopefully a future version will take care of the problem so we can just update normally.

    Thanks for the step by step Linn and neotechnomad
    It kind of works for me. I got through the steps and then on step 6 it just gets real slow to respond to any request. Like 5 minutes even to respond to activating the plugin. Now another 5 to get to settings and disable IP Address Discoverer.
    It finally got through the process and looks to be working now.

    But since I have about 50 sites to do this on, I think I will just disable the plugin until they fix it. 🙁

    Keep this open to receive any updates.
    Thanks.

    Same problem here!

    Thanks for the detailed steps guys, but I don’t havee time to mess around with something that will probably just break again. Am waiting for an update to fix this.

    @jberg1 & @bennygill
    When you click on the “Generate API Key” button, there is a checkbox for the IP Address Discoverer – just uncheck it and you do not have to go to the section to disable it.

    @linnalexandra Change your Step 6 to reflect this, please.

    @neotechnomad When I re-installed and re-activated the plugin, the Generate API window did not pop up – my previous API key was still filled in, perhaps because I optimized the database via phpMyAdmin instead of using the plugin you’re using? That’s why my steps are slightly different.

    I too am having this problem. I’m glad I tried updating my test site first before my real site. I went in via FTP and renamed the plugin (deactivating it) so now I can access my test site again. But I am not technical and I do not want to mess with all the the steps mentioned. I don’t even know how to optimize a database. Hopefully a fix will be coming for this soon.

    Optimizing the database is done through am optimizing plugin > wordpress.org/plugins/search/optimize/

    These plugins do this automatically. One of the operations is removing leftover components from uninstalled plugins.

    Install one of these and run after uninstalling the Sucuri plugin.

    – via ftp or Your Hosting Account > cPanel > File Manager > public_html > wp-content > plugins – rename the sucuri-scanner plugin directory (folder) to “sucuri-scannerX“, thus disabling the plugin

    – remain logged into your ftp or cPanel

    – Login to your site but DO NOT DO ANYTHING!

    – return to ftp or cPanel and rename sucuri-scannerX back to sucuri-scanner and log out of ftp or cPanel

    – return to your site’s dashboard and refresh your browser – Sucuri option will reappear in the WP Dashboard left menu

    – Go to Plugins Section and deactivate Sucuri plugin

    – Delete Sucuri plugin – a pop-up window should appear stating that the plugin and all associated data will be deleted

    – Run the Optimization plugin you installed

    – Install fresh Sucuri plugin and activate

    – In Sucuri plugin’s Settings – select ‘Generate API Key’ button at top – this will give a new API Key

    – Set up the Sucuri plugin according to your preferences

    I posted a reply detailing step by step instructions and the link to WordPress Plugin’s Optimizing plugins – but, for some reason, it is not showing up.

    Optimizing plugins can be found at WordPress Plugins section.

    Like I said, I am not comfortable with doing any of this. Who knows what problems I may encounter. Hopefully a developer is working on a fix.

    Add me to the list with the same issue. After two hours of research finally found that this release of the plugin is the root cause of not being able to login. The work around described above seems to be hit or miss with folks. Going to just leave it deactivated until the developer come up with the fix

Viewing 15 replies - 16 through 30 (of 46 total)
  • The topic ‘Cannot Login Since 1.8.6 Update’ is closed to new replies.