• Resolved neotechnomad

    (@neotechnomad)


    I cannot login to any of the sites I admin since the plugin update to 1.8.6.
    I have to rename the Sucuri plugin via FTP and then I am allowed to login – then rename the plugin via FTP back again.
    I can navigate the Dashboard, but when I logout, I cannot log back in.

    Please fix this.

Viewing 15 replies - 1 through 15 (of 46 total)
  • Same problem here.

    …and now I cannot navigate through the WP dashboard. Everything just hangs, then gives me a 404 error.

    The sites I admin are on three different hosts, including Godaddy, and they are all experiencing the same issue.

    This needs to be fixed.

    Error log from one of the affected sites:

    [27-Jun-2017 07:22:18 UTC] PHP Warning: require_once(src/sucuriscan.lib.php): failed to open stream: No such file or directory in /home/***/public_html/wp-content/plugins/sucuri-scanner/sucuri.php on line 207
    [27-Jun-2017 07:22:18 UTC] PHP Fatal error: require_once(): Failed opening required ‘src/sucuriscan.lib.php’ (include_path=’.:/opt/alt/php56/usr/share/pear:/opt/alt/php56/usr/share/php’) in /home/***/public_html/wp-content/plugins/sucuri-scanner/sucuri.php on line 207
    [27-Jun-2017 07:28:34 UTC] PHP Fatal error: Class ‘SucuriScanFileInfo’ not found in /home/***/public_html/wp-content/plugins/sucuri-scanner/src/option.lib.php on line 177

    After gaining access by renaming the plugin via ftp, logging in, then renaming the plugin via ftp back again – I can navigate anywhere within the admin except for the WP dashboard.
    It hangs and will not load the WP dashboard.
    Then, if I logout, I cannot log back in again. It hangs trying to connect, but never does. (…I let it sit for almost 5 minutes but it never logs in)

    The only solution for this is to uninstall the plugin and optimize your database if you have an optimizing plugin.
    Reinstall the plugin from the WP admin plugins section, get a new API Key, and reconfigure plugin.

    Performed this on all the sites with the issue and it resolved the problem.
    Note that logging in will take a little bit longer to load the WP admin dashboard.

    I was already logged in so was able to continue to do everything I wanted on the site APART from add new posts or pages. I.e. I could access dashboard and other plugins, just not add new content.

    @neotechnomad, I did as explained by you except the reinstall of Sucuri after uninstall and optimizing because I am affraid it can happen again and the cause is not clear to me.

    Uninstall the plugin and optimize your database if you have an optimizing plugin.
    Reinstall the plugin from the WP admin plugins section, get a new API Key, and reconfigure plugin.

    MAKE SURE that SUCURI > Settings > General > IP Address Discoverer and Reverse Proxy are disabled.

    The “IP Address Discoverer” is enabled by default when you are requested to obtain the API Key – UNCHECK the box for that option in the API Request pop-up window and it will be disabled.
    This seems to be the major issue.

    I did this on 6 different websites hosted on 3 different host servers with positive results.

    I have uninstalled the plugin, optimized the database and upon reactivating the new install per the above instructions, the site comes to a crawl and times out to a 404 page still.

    @jkuzma Did you check that SUCURI > Settings > General > IP Address Discoverer and Reverse Proxy are disabled?

    Same problem here, after I updated your plugin my admin panel is broken. I used Filezilla to rename the plugin, which deactivates it, and my admin panel is working again.

    Yeah … I update all my sites plugins from WP-Manage.
    They all have identical configs … all using Sucuri.
    On updating Sucuri on a single site … trying to login just hangs … get gateway error.
    Tried another site … same thing.
    My solution? I’m not going to bother updating until there is a fix.
    Regards Mark

    I am experiencing same thing. Renamed the plugin and can login to website(s). Wondering why this is listed as resolved since clearly it isn’t. Manage several websites after going through the process of followed neotecnomad’s instructions, but site login still takes a long time to load.

    Same thing happened to me on a site that auto-updated to the 1.8.6 release early this morning. Deleting the plugin was the only way I could access wp-admin without crashing the entire server. Looked like something was causing PHP to eat up all the available memory.

    I also started having this problem after the 1.8.4 update, and it’s not resolved by 1.8.6. On dozens of different hosting setups, the dashboard hangs and finally goes to a 504 or 502 error.

    I deleted the plugin folder via FTP, optimized the database as per @neotechnomad’s instructions above, and re-installed the plugin (now version 1.8.6) via the Add Plugins screen. Clicking Activate then caused the dashboard to time out again (so there was no opportunity to deselect IP Address Discoverer and Reverse Proxy).

    I’ve kept the plugin deactivated, but will continue to update it since that seems to be safe. I won’t reactivate until a fix has been confirmed.

Viewing 15 replies - 1 through 15 (of 46 total)
  • The topic ‘Cannot Login Since 1.8.6 Update’ is closed to new replies.