Cannot login or setup (7 posts)

  1. loybanks
    Posted 7 years ago #

    I'm about at my wits end with this one. I set up two other blogs without this aggravation. And I can't get any help out of GoDaddy.

    Not making a connection between the /blog/ files and the database, or at least I guess that's whats going on. The message I get is this....


    Error establishing a database connection

    This either means that the username and password information in your wp-config.php file is incorrect or we can't contact the database server at p41mysqll45.secureserver.net. This could mean your host's database server is down.

    * Are you sure you have the correct username and password?
    * Are you sure that you have typed the correct hostname?
    * Are you sure that the database server is running?

    If you're unsure what these terms mean you should probably contact your host. If you still need help you can always visit the WordPress Support Forums.


    I set up the MySQL properly. It shows up as it should under databases.

    My wp-config.php as follows......Any ideas out there or do you need more information? As always my thanks.

    // ** MySQL settings ** //
    define('DB_NAME', 'bm2008'); // The name of the database
    define('DB_USER', 'bmbanjo'); // Your MySQL username
    define('DB_PASSWORD', 'MM4P.Iwba!'); // ...and password
    define('DB_HOST', 'p41mysqll45.secureserver.net'); // 99% chance you won't need to change this value
    define('DB_CHARSET', 'utf8');
    define('DB_COLLATE', '');

    // Change SECRET_KEY to a unique phrase. You won't have to remember it later,
    // so make it long and complicated. You can visit http://api.wordpress.org/secret-key/1.0/
    // to get a secret key generated for you, or just make something up.
    define('SECRET_KEY', 'put your unique phrase here'); // Change this to a unique phrase.

    // You can have multiple installations in one database if you give each a unique prefix
    $table_prefix = 'wp_'; // Only numbers, letters, and underscores please!

    // Change this to localize WordPress. A corresponding MO file for the
    // chosen language must be installed to wp-content/languages.
    // For example, install de.mo to wp-content/languages and set WPLANG to 'de'
    // to enable German language support.
    define ('WPLANG', '');

    /* That's all, stop editing! Happy blogging. */

    define('ABSPATH', dirname(__FILE__).'/');

  2. loybanks
    Posted 7 years ago #

    As a follow up, I just noticed after first posting that when I keyed in the host name, the p41mysqll45.secureserver.net should have been p41mysql145.secureserver.net. Notice the sql followed by a 1...

    However that didn't solve the problem. Now I'm getting another message....

    Can’t select database

    We were able to connect to the database server (which means your username and password is okay) but not able to select the bm2008 database.

    * Are you sure it exists?
    * Does the user bmbanjo have permission to use the bm2008 database?
    * On some systems the name of your database is prefixed with your username, so it would be like username_wordpress. Could that be the problem?

    If you don't know how to setup a database you should contact your host. If all else fails you may find help at the WordPress Support Forums.

    So what I'm wondering is, should I go in and delete the existing database and set it up new once again? Or might anyone out there have any other suggestions? Or might this be a GoDaddy issue, even though they won't help me with it. As always my thanks.

  3. loybanks
    Posted 7 years ago #

    Another update...When I open up the database on the GoDaddy Server all is opening as it should so far as I no. But, I do notice that on the left under the username the words "no tables found in database".

    Maybe that's simply because they haven't been set up yet. But then again I haven't been able to link up, so maybe that's connected too! And around and around we go! :)


  4. Samuel B
    Posted 7 years ago #

    log in at godaddy and got to "databases - mysql"
    click on little pen icon beside database name.
    On next screen check the database values. If everything is correct in your wp-config.php from that screen - likely your password is wrong. You can edit the user and chage it.

  5. designsimply
    Posted 7 years ago #

    @loybanks, it seems like your database is setup, but the user is not properly associated with the new database or the user does not have the permissions it needs for the database. So, it's probably not that your password is wrong but it's that the database setup is not quite complete from the godaddy side. samboll is correct, you should login to godaddy and make sure everything matches exactly (for example, is the username supposed to be the same as the database name?). You also need to check that the username associated has enough permissions to select, insert, update, delete, etc. in the database.

    See managing databases at godaddy for how to check the database information.

  6. MichaelH
    Posted 7 years ago #

    At Godaddy the database name and database user are the same. Also note, Godaddy gives the database user all the privileges--you can't allow/disallow any particular privilege.

  7. designsimply
    Posted 7 years ago #

    Thanks MichaelH. I didn't know that about the database user and privileges at GoDaddy.

Topic Closed

This topic has been closed to new replies.

About this Topic