Support » Fixing WordPress » Cannot login after V3.5.1 Update

Viewing 10 replies - 1 through 10 (of 10 total)
  • Sorry to hear about that trouble, Angus.

    Did you have a look at this article in Codex?

    Not sure.,
    Try [Site URL]/wp-login.php
    because permalink need to update

    Thanks Pothi,
    I’ve done all the things in the Codex article list but cannot get any improvement – none of the logins work. They all return the “ERROR: Invalid username. Lost your password?” box.
    If I install a new WP onto my existing DB, the installation comes to “Already Installed – You appear to have already installed WordPress. To reinstall please clear your old database tables first.”
    That means it can find the DB. If I click OK, then it links to DB and renews the $User table with only the new “admin” login – and deletes all the others. Trouble is, WP cannot find anything else on the DB so I cannot get to any data.
    If I start a new installation with a blank DB, all is OK and the login works. However, as soon as I update the DB with the old tables, the login stops working, though WP can read all the other contents – except for the $Users table. As present:
    I have no clue what to do now….

    Hi Raja,
    I have looked at the wp-login.php but am now sure where to add, and exactly what to add.
    The Changing The Site URL Codex is a bit out of date. and now to clear.
    The suggestions:define `(‘WP_HOME’,’’);
    define(‘WP_SITEURL’,’’);` stops display.
    I tried a couple of the ones further down the page, but got error messages for the new lines, even if put at the top of the page.

    The trouble I didn’t change things, other than the auto-update. It only came to light when I logged out and could not log back in.

    Will 950 posts in the DB, a manual cut and paste update to a new installation is impossible.

    Any advice on how to fix a possible permalink error is appreciated!! 🙂

    Regards and thanks, Anguis

    Did you check the error log from your host and did you enable debugging in wp-config.php to see, if there are any clues to this?

    BTW, as Raja mentioned correctly, this seems to be an issue with the permalinks that do not work correctly on your site, as of now. I haven’t experienced a similar issue. May be you could backup your .htaccess file and empty it to see, if you could login?

    Hi Pothi,
    I messed around with the .htaccess and managed to shut it all down a few times. The present one is:
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ – [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    # END WordPress
    If you can suggest other rules to try, I’ll do that.
    I now have a list of debug items – thanks for that suggestion. Only trouble is, I can’t do the ones I tried to fix – just not enough knowledge 🙁
    The login report on the DB records each time I fail, but no data I can see on the reason.

    Regards and thanks, Angus

    Hi Pothi & Raja,
    Praise the Lord, the problem is solved! It was a combination of many things.
    I stripped down the DB and removed all that was computer generated. i.e. All that was left was my stuff and the options table.
    I then installed a new WP3.5.1 with nothing else – no plugins or theme and I got the DB connected. No front side working, but I got the admin panel back!
    I then reinstalled most of the plugins one at a time with direct auto-loads and activated them one at a time. At the same time I logged in and out of Admin on another browrser to make sure there were no conflicts.
    Slowly the front end came to life.
    When all was working I backed up a copy of the whole site and started to try themes. Again, testing, testing and testing, and slowly it came back to life.
    My DB is now 7Mb smaller and all is noticeably faster. Once I have it all back together, I’ll start debugging.
    Actually, I was surprised how much code in 3.5.1 gave debug error, saying that code has been updated on Codex since 2.+ 🙂

    Thanks again guys,
    Blessings, Angus


    Praise the Lord. Thanks buddy,



    Im having trouble. I tried upgrading to 3.7.1 and failed miserably. Some misplaced files i think, due to similar folder-subfolder names. I wasnt even getting the website or the website/wp-admin page.

    Finally got it back up and working by carefully running through and re-uploading my backup files to the server.

    Now I try logging in but I can’t login successfully. Im getting the invalid username and pass. I tried resetting the password via the link in the login page but after following the link form my email and entering the new password, I still get invalid username and pass…weird huh?

    What else can I do? I don’t know what stripping down a db means, nor do I know how to do it.

    pls hlp



    @marciokoko – this thread is about WP3.5.1 and is marked resolved – not relevant to your question. Please start a new thread as per:

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Cannot login after V3.5.1 Update’ is closed to new replies.