Support » Plugin: Theme My Login » Cannot Log Out

  • Resolved socialogles

    (@socialogles)



    Hello, I cannot logout with TML activated. I deactivated all plugins and found that I can log out properly, but when TML is on … it seems to lead to old logout page that I deleted and the logout link on the Admin bar is also incorrect. How do I update both of those logout links to the correct page?

    Thx … btw, this only started happening recently. Also… the shortcode works fine and the logout page display is correct. So the problem is confined to the actual function.

    • This topic was modified 9 months, 3 weeks ago by  socialogles.
Viewing 15 replies - 1 through 15 (of 17 total)
  • I’ve also started to experience this issue recently.

    I think the problem is that there is no _wpnonce parameter on the logout link: /login/?action=logout should be https://www.procopywriters.co.uk/login/?action=logout&_wpnonce=xyz Without this parameter, the logout action never succeeeds.

    @glenscott … I was thinking the same thing! I have the nonce when TML is deactivated but it disappears when TML is on.

    Another thing is that the Admin toolbar will say, “You are attempting to log out. … Do you really want to log out?”

    I tried to remove that message but it was mistake… resulting in an endless redirection that took down the entire site. So the code for that is no use.

    • This reply was modified 9 months, 2 weeks ago by  socialogles.
    • This reply was modified 9 months, 2 weeks ago by  socialogles.

    I’m unsubscribed from this topic, yet continue to receive E-mail notifications. Can someone, please, tell me why this is happening and suggest a solution that will prevent this from continuing.

    Miguel

    Plugin Author Jeff Farthing

    (@jfarthing84)

    The nonce parameter is added to the real logout page though. Why did you delete the original logout page?

    Thanks for your response, Jeff. It seems the solution to this issue is to re-create the Logout page and make sure the _tml_action = logout meta value is in place. I will give this a try.

    Can confirm that re-creating the logout page and adding the _tml_action=logout meta value (via phpmyadmin) fixed the logout links. Not sure why the logout page was deleted in the first place.

    @jfarthing84 Delete was a mistake. I had 2 logout pages going and deleted one… Bad:(

    I will try the solution offered by @glen_scott and report the results.

    @glen_scott how did you recreate the log out page? I seem not to be able to find the option. Also, the metavalue is option_name=”_tml_action” and option_value=”true” ?

    @socialogles did you get to recreate the logout page ???

    @jfarthing84 can you please indicate how to recreate the logout page for the ones like me that deleted it by accident! Please thank you!

    To re-create the logout page, go to your admin and go to Pages -> Add New. Give the new page the title “Logout” and click Publish. Look at the URL for the page ID, you’ll need this for the next step.

    Go into your MySQL backend, either via PHPMyAdmin or the mysql command line client and run the following command:

    INSERT INTO wp_postmeta(post_id,meta_key,meta_value) VALUES(postID, '_tml_action', 'logout');

    Thank you very much! I got it working now!

    [Moderator note: Please do not @ mention folks already in the thread.]

    • This reply was modified 9 months, 1 week ago by  Steve Stern.

    Didn’t work for me. Maybe I’m doing something wrong? I’m also getting the “you are attempting to log out …” and it gets stuck on that page.

    • This reply was modified 9 months, 1 week ago by  socialogles.

    are you replacing the post id of the page you create it in:

    INSERT INTO wp_postmeta(post_id,meta_key,meta_value) VALUES(postID, '_tml_action', 'logout');

    before you run it?

    @karlosuccess I’m sorry I didn’t see your reply sooner. I’m going to try again just to make sure I didn’t miss anything, and get right back.

Viewing 15 replies - 1 through 15 (of 17 total)
  • The topic ‘Cannot Log Out’ is closed to new replies.