Support » Plugin: iThemes Security (formerly Better WP Security) » Cannot log in – redirects to homepage

  • Resolved jnikkir

    (@jnikkir)


    After updating, I could no longer log in to my dashboard. I could navigate to /wp-admin/ just fine and enter my login details, but no matter what, I was immediately redirected to my homepage, and was not logged in.

    In order to access my dashboard, I renamed the better-wp-security plugin folder via FTP, and now I can log in as normal. On my plugins page, it lists “iThemes Security”, but it’s deactivated.

    I’m just wondering how exactly to proceed. Should I delete better-wp-security via FTP, and reinstall “iThemes” from scratch? Are there any other options?

    https://wordpress.org/plugins/better-wp-security/

Viewing 15 replies - 16 through 30 (of 85 total)
  • Same issue for me with the latest update. After the update i get kicked out of my admin, and cannot get back in. It keeps redirecting to my home page. I haven’t even set anything on the plugin.
    Luckily i’m only on my localhost testing pages, but i will have to remove this plugin on any of my current sites if the owners update and can’t get into their admin.
    We need some sort of response from the developers. Even if it’s to say we’re looking into it!

    Same here. I went into my pug in directory via FTP and removed the plugin and now I can access the Dashboard. Hopefully they will fix this soon.

    Same problem here too.

    I used the “Hide backend/login” option and I see the login form on the new login page, but once I submit my credentials, I’m redirected to the old admin page which displays a 404.

    I’m also never actually logged in, since I don’t see the admin toolbar on my site after logging in.

    Is there a way I can turn this off via FTP without deleting the entire plugin?

    Same! Login attempt redirects to home page, renaming folder in plugins gets me in, reactivating plugin in dashboard gets me white page. I’m also on 1&1.

    I’d say I’m glad I’m not the only one with this problem, but obviously I wish we weren’t dealing with this in the first place.

    To clarify – the issue (mine and many others on this thread) is that we’re getting redirected to the homepage after “login”. There’s no 404 error, just a redirect – from all things /wp-admin back to the homepage. As with jamesewelch’s situation (though he’s actually seeing a 404), there’s also no admin toolbar on the site after “logging in” and being redirected to the homepage.

    I hope we get some answers from the developers. Radio silence is quite disconcerting. Thinking of just deleting better-wp-security via FTP and finding a new security plugin. This has not been handled well.

    Same here.

    I have updated 8 sites with no problems, but on one, I cannot log in. Deleting the plugin folder allows me to log in.

    Lunarpages hosting
    WP 3.8.1
    Weaver II theme
    PHP Version: 5.3.14
    MySQL Version: 5.1.70-rel14.8

    Here’s how I fixed it. This only applies to people who have enabled “hide backend” option of the plugin and are now unable to log into their web sites.

    If using FTP client
    1. Use FTP to log into /wp-content/plugins
    2. Rename “better-wp-security” to a different name
    3. Log into wordpress using /wp-admin (it may take a few seconds)
    4. I used Adminer plugin to query/access my db
    5. Select the “wp_options” table
    6. Filter using ‘select’ where ‘option_name’ ‘=’ ‘itsec_hide_backend’
    7. Select and Delete that single row, this will reset that option and disable the hide backend option
    8. Rename the plug-in back to original name

    If you have access to a database query/editor via host control panel or other means
    1. Delete the hide backend option, so that it becomes disabled by default:
    Delete from wp_options where option_name = ‘itsec_hide_backend’

    I don’t have “hide back end” selected — I was kicked out of the site when I tried to activate the plugin. So maybe there’s two different problems happening. For some, it’s the “the hide the backend” selection which can be fixed by deselecting that.

    Others of us must have some other conflict.

    I should have noted previously, the theme is custom, using WP 3.8.1, the php version is 5.2.17.

    Plugins I’m using that I don’t use on every other site are: Display Widgets, Reflex Gallery and Responsive Image Maps. The others are things like TinyMCE Advanced, etc.

    Just had the exact same issue. I renamed the plugin folder in the directory and hey presto I can get to my dashboard again. Not going to reactivate this until I hear it’s fixed.

    Wish I could say that jamesewelch‘s fix worked (I *do* have hide backend enabled) but the results were the same, I still get dumped back to the home screen. Even though they didn’t work for me, thanks for writing those easy to follow instructions, James.

    At this point, if I can find the previous 3.x version of BWPS somewhere, I’ll probably just reinstall it and keep it in place until this issue gets resolved.

    Got it. Saw it in another post just right after I posted mine, and have it installed and activated now. Thanks!

    Plugin Author iThemes

    (@ithemes)

    Hello All,

    Thanks for reporting this and my apologies for the trouble. We’re actively looking into this and a release for it is coming soon.

    Thanks for your patience,

    Gerroald

    I fond out the cure for me, I saw a folder wp-content/uploads/ithemes-security, there is one file in there named isec_away.config, open the website folders with an ftp program and download that file anywhere and then delete it from the server.

    try open again the dashboard of wordpress (to me it reborn), open SECURITY from the menu, once on the dashboard of the plugin, scroll visually to the section “Security status” and click on the “completed” tab.

    on the line of the away mode, click edit and uncheck the thickbox

    DO NOT press save yet

    Return to the ftp program and upload again the isec_away.config in the original position

    go back to wordpress and press save

    This actions to me had restored the plugin working!

    Same issue here… Sigh. Loops back to website home page.

Viewing 15 replies - 16 through 30 (of 85 total)
  • The topic ‘Cannot log in – redirects to homepage’ is closed to new replies.