Support » Plugin: Wordfence Security - Firewall & Malware Scan » Cannot log in as Admin page 404

  • Resolved Krammig

    (@krammig)


    I initially had set both 2FA and hidden Login within the WordFence and that caused a bunch of issues.

    Disabling both 2FA and the hidden Login seems to have caused Wordfence to show me a 404 when trying to log into WP-Admin

    I deleted the Wordfence plugin folder however I am still getting the 404 when trying to login.

    I have also removed the code from the wp-settings / wp-config (can’t recall which one) that referred to Wordfence.

    The contents of the following are blobs – which is faor enough – so I cannot check the contents there.

    a) if I delete the wf Tables will that get me back to a normal site ?

    b) or if I delete the contents of columns wf_home_url and wf_site_url in the wfconfig table, will that get me back to being able to log in ?

    I might also add that trying to log in on the home page under Login says 2FA is required but there is no means of actually entering it in.

    Thanks

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Support WFGerroald

    (@wfgerald)

    Hey @krammig,

    Can you please share the contents of your htaccess file?

    Can you try renaming your htaccess to something like htaccess.bak using (s)FTP or your hosting control panel?

    Please let me know.

    Thanks,

    Gerroald

    Good Morning Gerroald,

    Thank you for the reply. As requested,

    
    <files wp-config.php>
    order allow,deny
    deny from all
    </files>
    
    # Block the include-only files.
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^wp-admin/includes/ - [F,L]
    RewriteRule !^wp-includes/ - [S=3]
    RewriteRule ^wp-includes/[^/]+\.php$ - [F,L]
    RewriteRule ^wp-includes/js/tinymce/langs/.+\.php - [F,L]
    RewriteRule ^wp-includes/theme-compat/ - [F,L]
    </IfModule>
    
    # BEGIN WordPress

    Cheers

    • This reply was modified 4 months, 2 weeks ago by Krammig.

    By the way I am running on a Windows Server 2016

    Cheers

    Hello Gerroald,

    My Apologies….

    I have been sitting here scratching around the site folder and spotted a folder called – wps-hide-login

    Removed that and now I can log in. I had no idea that was there, sorry to have wasted your time.

    Cheers
    Mark
    .

    Plugin Support WFGerroald

    (@wfgerald)

    Hey @krammig,

    No waste of time at all, just happy to hear you were able to track it down.

    Please let us know if anything else comes up.

    Thanks,

    Gerroald

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.