Support » Plugin: MP3-jPlayer » Cannot locate audio with hotlinked files

  • polonos

    (@polonos)


    Hello all,

    thanks for this plugin. Looks and works great! However, I have some mp3’s hotlinked on kiwi6.com because my site is on a free host and there are bandwidth limitations. I’ve made a playlist and it works great but sometimes, it cannot locate the next file to play. If I press stop and then play again, the file plays fine… It happens with all the files, sometimes… I assume this is because the files are hotlinked. It looks like the plugin should try again if it cannot find a file, before throwing the message “cannot locate audio”. When this happens, the player stays idle until I press some button. Thanks beforehand for your help

    https://wordpress.org/plugins/mp3-jplayer/

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Author simon.ward

    (@simonward-1)

    Hello, could you post a link to your site so I can take a look?

    Thread Starter polonos

    (@polonos)

    Hello Simon,

    thank you for your reply. Check the first playlist on the link I have provided. If you let it play, at some point it will happen. To reproduce the error quickly, click on the song titles in the playlist until it happens. Sometimes it happens after a couple of clicks, sometimes it will take more, but you will see it. I love the look of this plugin and I wouldn’t want to use a different one but this issue is a huge problem. The songs on the first playlist are hotlinked on kiwi6.com. I added some tracks in the wordpress media library to test it out and it still happens! By the way, the text on the page might look garbled on your pc because the website is in greek, I’m still working on it and the english translation is not yet ready. Thanks for your help.

    http://axaireutoi.tk/new/radio/

    Plugin Author simon.ward

    (@simonward-1)

    The problem is actually with the hosting and not the plugin. You can see exactly the same thing happen when you paste one of your audio urls straight into the browser address bar. It will fail every now and again.

    My advice would be to speak to the hosts at kiwi6 and explain to them the issue, they may be able to help, or allocate you more resource.

    Thread Starter polonos

    (@polonos)

    Hello Simon,

    ok I see what you mean. However, if I immediately retry the same track, it will play. Hence, don’t you reckon it might be a good idea to tell the plugin to retry a file 3 times before it actually commits to the “can’t locate audio” message? I mean, I don’t think kiwi6 is gonna give me more resources and even if they did, I can still imagine the same thing happening from time to time. I bet many other people have come across the same problem. Unless there is some other issue involved, I think this would be a beneficial feature for the plugin. Thanks for your help.

    Plugin Author simon.ward

    (@simonward-1)

    That’s a fair point, let me see what I can come up with.

    Thread Starter polonos

    (@polonos)

    Hello Simon,

    nice man! Much appreciated. Looking forward to it.

    Thread Starter polonos

    (@polonos)

    Hello Simon,

    how’s it going? Have you looked into this at all? see you around

    Bumping.

    I’ve got the same situation with Shoutcast streams: generally it works fine but sometimes (in Chrome often) it just cannot start (‘Can’t locate audio’). Clicking ‘play’ once or twice more makes things happen but sometimes it needs to be clicked several times. Streams are ok and work flawlessly anywhere else.

    I like an idea of forcing the player to do few more tries before giving up with ‘Can’t locate audio’. It should do the job and waiting for the stream to start for few more seconds won’t be a problem for anyone.

    It would be wonderfull if it works – I’d like to remove other players (outdated and sometimes still on flash) from my projects and stick with this one.

    Thanks in advance,
    Chris

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Cannot locate audio with hotlinked files’ is closed to new replies.