Support » Plugin: Post Thumbnail Editor » Cannot load pte-edit.

Viewing 15 replies - 1 through 15 (of 21 total)
  • Same for me, I tried the same thing and it still does not work.
    Any ideas how to fix it ?

    Plugin Author sewpafly


    What browsers are you using? The version numbers would help. Can you explain what’s not working a little bit ? Does it not load or have problems cropping? What happens if you try a different browser?

    I have tried with different browser and it’s the same every time.
    When I click on Thumbnail in the media section I have the following message :

    Cannot load pte-edit.

    And when I click on Post Thumnail Editor I have got an empty popup window.

    Plugin Author sewpafly


    What is the url that is being generated look like?

    The user that you are logged on with, does it have full permissions?

    Can you provide a screenshot of the message that says “cannot load pte-edit”? (Or describe the page, does it have the normal wordpress admin interface? and then where the content would be, is that where the message is? — I might want to see a copy of the html itself).

    If you were using 2.0.0-beta, you can download that from here if you want to go back. (Or just try that version and let me know if it fixes the problem). I can provide links for other versions as well.

    Also, enable debugging @ Settings → Post Thumbnail Editor.

    I tried to use the beta but same thing.
    I have full permission.
    The page is empty except for the message.

    <!DOCTYPE html>
    <!-- Ticket #11289, IE bug fix: always pad the error page with enough characters such that it is greater than 512 bytes, even after gzip compression abcdefghijklmnopqrstuvwxyz1234567890aabbccddeeffgghhiijjkkllmmnnooppqqrrssttuuvvwwxxyyzz11223344556677889900abacbcbdcdcededfefegfgfhghgihihjijikjkjlklkmlmlnmnmononpopoqpqprqrqsrsrtstsubcbcdcdedefefgfabcadefbghicjkldmnoepqrfstugvwxhyz1i234j567k890laabmbccnddeoeffpgghqhiirjjksklltmmnunoovppqwqrrxsstytuuzvvw0wxx1yyz2z113223434455666777889890091abc2def3ghi4jkl5mno6pqr7stu8vwx9yz11aab2bcc3dd4ee5ff6gg7hh8ii9j0jk1kl2lmm3nnoo4p5pq6qrr7ss8tt9uuvv0wwx1x2yyzz13aba4cbcb5dcdc6dedfef8egf9gfh0ghg1ihi2hji3jik4jkj5lkl6kml7mln8mnm9ono
    <html xmlns="" lang="fr-FR">
    	<meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
    	<title>WordPress &raquo; Erreur</title>
    	<style type="text/css">
    		html {
    			background: #f9f9f9;
    		body {
    			background: #fff;
    			color: #333;
    			font-family: sans-serif;
    			margin: 2em auto;
    			padding: 1em 2em;
    			-webkit-border-radius: 3px;
    			border-radius: 3px;
    			border: 1px solid #dfdfdf;
    			max-width: 700px;
    		h1 {
    			border-bottom: 1px solid #dadada;
    			clear: both;
    			color: #666;
    			font: 24px Georgia, "Times New Roman", Times, serif;
    			margin: 30px 0 0 0;
    			padding: 0;
    			padding-bottom: 7px;
    		#error-page {
    			margin-top: 50px;
    		#error-page p {
    			font-size: 14px;
    			line-height: 1.5;
    			margin: 25px 0 20px;
    		#error-page code {
    			font-family: Consolas, Monaco, monospace;
    		ul li {
    			margin-bottom: 10px;
    			font-size: 14px ;
    		a {
    			color: #21759B;
    			text-decoration: none;
    		a:hover {
    			color: #D54E21;
    		.button {
    			display: inline-block;
    			text-decoration: none;
    			font-size: 14px;
    			line-height: 23px;
    			height: 24px;
    			margin: 0;
    			padding: 0 10px 1px;
    			cursor: pointer;
    			border-width: 1px;
    			border-style: solid;
    			-webkit-border-radius: 3px;
    			border-radius: 3px;
    			white-space: nowrap;
    			-webkit-box-sizing: border-box;
    			-moz-box-sizing:    border-box;
    			box-sizing:         border-box;
    			background: #f3f3f3;
    			background-image: -webkit-gradient(linear, left top, left bottom, from(#fefefe), to(#f4f4f4));
    			background-image: -webkit-linear-gradient(top, #fefefe, #f4f4f4);
    			background-image:    -moz-linear-gradient(top, #fefefe, #f4f4f4);
    			background-image:      -o-linear-gradient(top, #fefefe, #f4f4f4);
    			background-image:   linear-gradient(to bottom, #fefefe, #f4f4f4);
    			border-color: #bbb;
    		 	color: #333;
    			text-shadow: 0 1px 0 #fff;
    		.button.button-large {
    			height: 29px;
    			line-height: 28px;
    			padding: 0 12px;
    		.button:focus {
    			background: #f3f3f3;
    			background-image: -webkit-gradient(linear, left top, left bottom, from(#fff), to(#f3f3f3));
    			background-image: -webkit-linear-gradient(top, #fff, #f3f3f3);
    			background-image:    -moz-linear-gradient(top, #fff, #f3f3f3);
    			background-image:     -ms-linear-gradient(top, #fff, #f3f3f3);
    			background-image:      -o-linear-gradient(top, #fff, #f3f3f3);
    			background-image:   linear-gradient(to bottom, #fff, #f3f3f3);
    			border-color: #999;
    			color: #222;
    		.button:focus  {
    			-webkit-box-shadow: 1px 1px 1px rgba(0,0,0,.2);
    			box-shadow: 1px 1px 1px rgba(0,0,0,.2);
    		.button:active {
    			outline: none;
    			background: #eee;
    			background-image: -webkit-gradient(linear, left top, left bottom, from(#f4f4f4), to(#fefefe));
    			background-image: -webkit-linear-gradient(top, #f4f4f4, #fefefe);
    			background-image:    -moz-linear-gradient(top, #f4f4f4, #fefefe);
    			background-image:     -ms-linear-gradient(top, #f4f4f4, #fefefe);
    			background-image:      -o-linear-gradient(top, #f4f4f4, #fefefe);
    			background-image:   linear-gradient(to bottom, #f4f4f4, #fefefe);
    			border-color: #999;
    			color: #333;
    			text-shadow: 0 -1px 0 #fff;
    			-webkit-box-shadow: inset 0 2px 5px -3px rgba( 0, 0, 0, 0.5 );
    		 	box-shadow: inset 0 2px 5px -3px rgba( 0, 0, 0, 0.5 );
    <body id="error-page">
    	<p>Impossible de charger pte-edit.</p></body>

    There is a conflict with the woocommerce extension.

    Works fine without.

    Any idea why ?


    Plugin Author sewpafly


    Thanks for finding that, I’ll look into it. @bartdevuyst – could you be having a plugin conflict as well?

    Your welcome.

    I’m using Woocommerce as well. Firefox 19.0.2. It doens’t load anything; just a blank wordpress error page with one error message about ‘cannot load pte-edit’.

    However, disabling Woocommerce fixes this issue. I’d love to see an update to fix this in the latest Woocommerce (2) version because your plugin is of high importance to a particular client website (which runs entirely on Woocommerce).

    Thanks in advance.

    Plugin Author sewpafly


    So this was a hard one to track down, but the fix was really easy. Woocommerce was looking for a common input parameter (post), so I changed mine to be pte-id. To see this change you can get a zip @ the location below.

    I believe this is resolved, but I’ll wait for both of you to weigh in.

    Download here.


    The plugin works just fine with Woocommerce now. Thanks again for the fix.

    In the time that your plugin wasn’t working with Woocommerce I tried another one: ‘Crop-Thumbnails’. There is something I prefer with that one: It locks the default aspect ratio of the original images size in the crop editor. This saves a lot of time compared to ‘Post Thumbnail Editor’ where you have to do some selections first to lock the ratio.

    I like the fact that your plugin allows undoing a crop (i.e. the new save button). This is great when you’re not sure about a decision made. Again (very subjectif, I know) this looses me a lot of time because I (and my client) have to recrop hundreds of images AND hit that save button over and over again after each new crop. It could be great if the save/confirm button is optional for people who need to work a lot faster. Just nitpicking, but these things make the difference between a good and a perfect plugin.

    Thanks again for the fine update.

    thanks a lot it works perfectly, well done.

    Plugin Author sewpafly


    @bartdevuyst – I’ve added some features, I was wondering if you would test them for me. You can download them here: This release sets the default aspect ratio to the original images aspect ratio (it changes when you select a cropped thumbnail size – or if there is only one type of thumbnail size, it will use that instead of the images aspect ratio).

    Additionally in the options you can now select a “crop and save” option that will bypass the image verification step.

    Let me know if you have any suggestions or problems!

    Thanks Sewpafly,

    I tried it out. Looks great! The aspect ratio of the original image works perfect! Much better.

    Save and crop option is also very good!

    Another suggestion: 🙂
    After hitting ‘Crop and save’ it would feel a lot more logical to see the cropped image instead of the original. You know, like in an image editor. I know you can view the result in the ‘View’ tab but an instant result could be very nice.

    Thanks for the updates. It’s fun to help out.

    Plugin Author sewpafly


    You’re right about seeing the image. Now that you mention it it’s totally obvious. I pushed out that change just now (to the same url).

Viewing 15 replies - 1 through 15 (of 21 total)
  • The topic ‘Cannot load pte-edit.’ is closed to new replies.