WordPress.org

Support

Support » How-To and Troubleshooting » “Cannot load akismet-key-config” error

“Cannot load akismet-key-config” error

  • I upgraded http://www.policycommons.org to v. 2.7 yesterday and then tried to install Akismet to stop all the spam I’m getting.

    But I’m not able to enter the WordPress API key. When I click on a “You must enter your WordPress.com API key for it to work.” prompt I get an error page that only says “Cannot load akismet-key-config.”.

    I thought maybe this was because of where I’m hosting, but I installed Akismet on another blog on the same server (version 2.6 though) and it worked fine.

    Did I mess up the installation? I’m running this installation out of a different directly from the blog address. Could that be related? Thanks for tips.

Viewing 4 replies - 1 through 4 (of 4 total)
  • Did you find a solution? I’m having the same issue with 2.7.1 and Akismet.

    I didn’t learn anything and dropped it. I should really fix it though so if you figure it out, please let me know!

    dwitzel — did you also get the problem where the appearance editor and plugins editor isn’t accessible through the Dashboard? I found a Web site that addresses this but they say it’s permissions and I’m reluctant to change my permissions (CHMOD). My host tried that and it didn’t work.

    See the thread here: http://www.hacktrix.com/fixing-the-blank-page-problem-after-wordpress-27-upgrade#comment-1014

    I found lots of posts related to this issue on the WordPress forum but no one is posting any solutions! It’s maddening.

    I downloaded 2.7.1 again and installed it for a second site and I’m getting the same issues with Akismet and the appearance and plugin editors.

    Ugh!

    Hi guys,

    I just downloaded the Akismet plugin and manually entered the API in the akismet.php file on line 17: $wpcom_api_key = ‘PUT API HERE’;

    Couldn’t find any other solution…

    N

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘“Cannot load akismet-key-config” error’ is closed to new replies.
Skip to toolbar