WordPress.org

Forums

Wordfence Security
Cannot kill a running scan 5.9.1 (4 posts)

  1. Ian McLeish
    Member
    Posted 11 months ago #

    Hi, updated to the latest version today 5.1.5. Set a scan to run this morning, and it has been stuck on

    Scanning file contents for infections and vulnerabilities and
    Scanning files for URLs in Google's Safe Browsing List

    for 6 hours. I cannot kill the running scan, I have tried repeatedly, but it does nothing. A quick "Wordfence is working" red popup, but then nothing. I tried to disable the plugin- I thought that might do it, but no, on re-enabling the plugin it is still stuck at the same point.

    I would be happy to let it stay stuck except that a previous scan was stuck earlier on an older version, and I was able to kill that one before updating- that updated automatically after I checked the box in the options, but only since this update and stuck scan, I cannot insert media into posts- the media screen comes up, but then just sits there with the little "working" circle thing going round- I wonder if my resources are being sucked up by the stuck scan?
    Any suggestions would be gratefully received,
    TIA

    https://wordpress.org/plugins/wordfence/

  2. barnez
    Member
    Posted 11 months ago #

    In Wordfence - Options there is an option to "Delete Wordfence tables and data on deactivation?"

    Also, this plugin is designed to help when you have issues with Wordfence functionality:
    http://wordpress.org/plugins/wordfence-assistant/

    Good luck!

  3. Wordfence
    Member
    Plugin Author

    Posted 11 months ago #

    Try setting the following option to 10:

    Maximum execution time for each scan stage

    This is on your Wordfence options page. Then save, then retry a scan. Might help the scan finish.

    Also consult with your hosting provider, ask them if there are any errors in our error logs you should be worried about.

    Regards,

    Mark.

  4. Ian McLeish
    Member
    Posted 11 months ago #

    Thanks for the suggestions, and your speedy replies.

    I got this sorted- I got an email from my ISP this morning advising me that due to a brute force attack on my site, their (shared) server was crawling- they had renamed ajax-admin.php and replaced it with a blank one to reduce server loading. I wish I had seen the email sooner- I spent most of yesterday trying to work out why WF wouldn't work properly, and I couldn't insert media into posts- turns out I was not as logged in as I thought I was!

    Just to be clear, the original question was about a problem not caused by Wordfence.

    Thanks again, and sorry to bother you. (Would you guys think that is a reasonable way to mitigate a sustained attack??????) There seems to be no penetration, and according to the WordPress Hardening article, as I have htaccess/ htpassword protected the wp-admin folder, the bots shouldn't even be getting to that file??

    Cheers

Reply

You must log in to post.

About this Plugin

  • Wordfence Security
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic