Support » Fixing WordPress » Cannot Install/Update Plugins Since Upgrade to 3.2

  • Hi,

    I wonder if anyone has had this same issue since upgrading to 3.2 –

    When I try to install/update plugins I get an error:

    ‘Download failed. Destination directory for file streaming does not exist or is not writable.’

    I had a feeling this would be a permissions problem so I went about checking all the permissions on the installation. However, they all seem to be correct.

    I assume I will have the same problem when trying to upgrade my WP installation the next time an update is available.

    Has anyone had any experience with this? Perhaps it’s a problem with my server’s PHP installation.


Viewing 15 replies - 1 through 15 (of 25 total)
  • Seems a problem of permissions after the installation as it happens with the buttons of the Visual Editor.

    As I said on this post:

    Check folders & files and change 600 permissions to 644. I’ll look first on:
    and the others Plugin folders.

    Hi xxxxbyte,

    Thanks for your reply.

    I read through the ‘Visual Editor Buttons’ post and didn’t find too much that was helpful. I did recall not updating the wp-config.php when I installed 3.2, so I tried that, but no improvement.

    I’m going to pursue with the permissions on the file system, as you suggested.

    Can anyone tell me the correct permissions for the following files and directories? I’ve indicated what mine are currently set to.

    / (755)
    wp-includes/ (755)
    wp-admin/index.php (644)
    wp-admin/js/ (755)
    wp-content/themes/ (755)
    wp-content/plugins/ (755)
    wp-admin/ (755)
    wp-content/ (755)

    In answer to your questions, all my plugin directories are set to 755. Does that sound right to you?

    Thanks for your help with this.


    Folders are ok.., but what about the files?

    A folder with 755 didn’t have to be full of 755 files. Check the files of the plugin folder and you’ll see 😉


    OK, I’ve checked all the directories and files within the plugins directory and they seem fine. 755 on the directories and 644 on the files.

    This isn’t really a problem that exists with one single plugin. More of an issue with the installation/update process.

    I’ve got a feeling that this is a hosting/PHP config issue. I’m going to do some digging on this.

    Those permissions look alright, This could very well likely be a server configuration issue, specifically, the Download might be attempting to save it in a temporary directory which you don’t have write access to.

    As a test only, can you try changing the permissions on wp-content to 775 or 777?

    Thanks for that, Dion.

    I tried changing the permissions on wp-content to both 775 and 777 with no joy.

    I just remembered from the previous version of WP I had installed that the temp files were saved in the plugins directory. However, I’m not sure I’ve ever been able to carry out an auto-install of any plugin/update before on this particular site.

    I seem to recall clearing out a lot of these temp install files that never completed.

    I think I am going to get in touch with the host and see if we can work this out.

    Thanks for your input.

    If your host can’t help, Please give me a yell, as there are a few other options I can think of as “workarounds”

    (I’ve got email notifications of this thread, so just post :))

    Hey, anything you can tell me would be great. I’m open to anything at this point 🙂

    My host is notoriously hard to get hold of and I’m short on time to complete the re-vamp of the website in question.

    It sounds like your host might have your Temporary files directory set to one which you don’t have access to.

    I’d try adding the following to your wp-config.php file to force it to use the wp-content directory
    define('WP_TEMP_DIR', ABSPATH . 'wp-content/');

    It’s not the best idea to do that as a first and final resort, as other things within WordPress (and PHP in general) may need to store temporary files as well (and only the upgraders will respect that constant I believe)


    OK, I added that line to the wp-config.php file and tried it again, no joy, same error.

    So I tried easing the permissions on the wp-content directory to 775 and got the same error.

    Finally, I tried again after chmod to 777 and it worked!

    It seems like the server can’t handle the normal WP permission structure for some reason. Kind of sounds like a user or role-based server issue to me.

    What do you think?

    Sounds like

    1. The server has set the Temporary directory to a directory which you don’t have write access to
    2. You’ve had to create a temporary directory yourself (by chmod’ing it to 777 and setting the constant).

    So, definately sounds like a server configuration issue to me, one which WordPress (and any other web based application) can’t really work around.



    I had this issue and resolved it by turning off ‘php safe mode’ from server control panel.

    Thanks guys. I finally got in touch with my host and they got back to me saying that they’d fixed the issue (it does work now) but from what I can see, all they’ve done is relax the permissions on all of the WP directories.

    Not a fix in my eyes!

    I will get back to them about the ‘PHP safe mode’ option and post back here.

    Dion – They did fix the temp file issue, so it’s now using wp-content as the temp directory. Thanks for your input.

    PHP Safe Mode was “On” and I turned it off and everything worked fine…

    Yes, that’s right! I have the same error and just turned PHP safe mode off. Everything working fine. 🙂

Viewing 15 replies - 1 through 15 (of 25 total)
  • The topic ‘Cannot Install/Update Plugins Since Upgrade to 3.2’ is closed to new replies.