Cannot Install Plugins "Unexpected HTTP Error" (4 posts)

  1. TheSeoGuy
    Posted 5 years ago #

    New installation of WP3.01 - no themes or plugins installed at;

    1.)Dashboard shows "WP HTTP Error: name lookup timed out" on Incoming Links, WordPress Blog & Other WordPress News.

    2.) Plugins / Add New: a search gives "An Unexpected HTTP Error occurred during the API request."

    3.) Tools / Import / Install Importer /Blogger - "An Unexpected HTTP Error occurred during the API request."

    A repeating log file error e.g.: [23-Aug-2010 18:00:39] PHP Warning: Cannot modify header information - headers already sent by (output started at /home/jowimcon/public_html/photo-blog/wp-includes/class-http.php:1) in /home/jowimcon/public_html/photo-blog/wp-includes/pluggable.php on line 890

    That one may have been eliminated when I deleted and replaced all WP files.

    So far, I've read all the posts on this problem and;
    a - changed 'timeout' in /wp-includes/class-http.php from 5 to 30
    b - tried to activate the Core Control plugin but that killed WP
    c - file / dir permissions are correct
    d - user / group permissions on the server are correct

    When none of that helped, I deleted all files (except wp-config) and FTP'd a fresh version in but the problem persists...

    The hosting guy is very helpful and he is as perplexed as I am.

    Does anyone have any helpful suggestions?

    Kind regards

    Ben Kemp

  2. SexyDawnT
    Posted 5 years ago #

    I am having these same issues suddenly. My blog has been clicking along fine and then yesterday - BOTH of my blogs started this behavior.

    Has anyone found a solution?

  3. optimus203
    Posted 5 years ago #

    @SeoGuy - did you ever resolve this issue? I'm having the same error and cannot find a solution.

  4. tophertopher
    Posted 5 years ago #

    This worked for me after scouring the 'net for hours:

    Prior to WordPress 3.0
    Edit file http.php in directory wp-includes and find the http timeout setting. It is by default set to 5. Increase to 30 or 60.
    'timeout' => apply_filters( 'http_request_timeout', 60);

    WordPress 3.0 and after
    Edit file plugin-install.php in directory wp-admin/includes and find the timeout setting. It is by default set to 15. Increase to 60.
    $request = wp_remote_post('http://api.wordpress.org/plugins/info/1.0/', array( 'timeout' => 60, 'body' => array('action' => $action, 'request' => serialize($args))) );

Topic Closed

This topic has been closed to new replies.

About this Topic


No tags yet.