Support » Fixing WordPress » Cannot insert an image

  • When I try and insert an image in a page, I can successfully upload the image or choose an image from the media library but when I click on the “Insert into post” button the “Add an image” dialog box goes white and just hangs there.

    The image is never inserted into the post or page.

    I have cleared my FF cache and even tried Google Chrome to make sure no FF plugins or settings were at fault.

    Any help you could give to over come this little snag would be greatly appreciated.

Viewing 6 replies - 1 through 6 (of 6 total)
  • esmi


    Forum Moderator

    Have you tried:

    – deactivating all plugins to see if this resolves the problem? If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    – switching to the default theme to rule out any theme-specific problems?

    resetting the plugins folder by FTP or phpMyAdmin? Sometimes, an apparently inactive plugin can still cause problems.

    – re-uploading the wp-admin and wp-includes folders from a fresh download of WordPress?

    – increasing the memory available to PHP?

    Thanks for the pointers.

    First I re-installed wp-admin with no change. Then, I re-installed wp-includes with no change.

    Then, I turned to testing my 34 plugins. It took a while, but I tracked the problem down to 2 plugins that come with the Prestige Dark vol.1 1.0 by Digital Cavalry theme.

    The two offending plugins re Digital Calvary Newsletter System and Digital Calvary Voting System. I have made a video of the issues and forwarded it to the authors of the theme and plugins.

    Thanks for your help!



    Forum Moderator

    No problem. Glad to hear that you managed to find the culprits.

    Hi Jim

    I am battling to get my theme to do what I want. I cannot get the slider to work in the sidebar, and I have been trying for 2 days. If you could help me or point me in the right direction I would appreciate it a lot!

    My mail address is

    Thank you

    thanks for the help on the image upload. Took out the newsletter and voting plugins and now it’s working.



    I was using Premium Slider by Matt Ruddy, but it didn’t have the functionality I needed. Installed TheThe Image Slider (yes, TheThe) and it handled my needs. I didn’t disable Premium Slider. Got the white box on image insert, found this post and disabled Premium Slider. Worked on the first try. Thanks for sharing the info!

    Note: Premium Slider works great on its own.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Cannot insert an image’ is closed to new replies.