Support » Plugin: Disable Admin Notices individually » Cannot Hide Webcraftic Pro Version message

  • In the newest free version 1.2.1 of your plugin, regardless of hiding your message, this message still appears each session:

    “Disable Admin Notices Individually:
    Thanks for using the Disable admin notices plugin! If you need support or all the features of the plugin, please buy the pro version”

    I’ve been a long time user of this plugin, and this is a recent occurrence that I’m seeing on several websites.

    Is this intentional to promote your premium version? Or is this a bug?

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author Artem

    (@webtemyk)

    Hello.

    We made this notification for promotion, but it had to be hidden forever. We are already working on fixing this bug.

    Hope this is fixed in newer versions. I solved problem by editing the plugin file disable-admin-notices/admin/boot.php and commenting out the section below. Please do so at your own discretion and test first! Remove or comment out:

    
    /**
     * Print admin notice: "Would you like to send them for spam checking?"
     *
     * If user clicked button "Yes, do it", plugin will exec action,
     * that put all unapproved comments to spam check queue.
     */
    add_action( 'wbcr/factory/admin_notices', function ( $notices, $plugin_name ) {
    	if ( $plugin_name != WDN_Plugin::app()->getPluginName() ) {
    		return $notices;
    	}
    
    	$page_url = 'https://clearfy.pro/disable-admin-notices/';
    
    	$notice_text = sprintf( __( 'Thanks for using the Disable admin notices plugin! If you need support or all the features of the plugin, please buy the pro version <a href="%s">Get PRO</a>' ), $page_url );
    
    	$notices[] = [
    		'id'              => 'wdan_get_premium',
    		'type'            => 'success',
    		'dismissible'     => true,
    		'dismiss_expires' => 0,
    		'text'            => '<p><strong>Disable Admin Notices Individually:</strong><br>' . $notice_text . '</p>'
    	];
    
    	return $notices;
    }, 10, 2 );
    
    • This reply was modified 10 months, 1 week ago by Yui. Reason: please use CODE button for proper formatting

    Thank you @helpfulpress
    Worked like a charm
    Regards

    Plugin Author Alexander Kovalev

    (@alexkovalevv)

    The bug has been fixed. We’ve improved the notification filter. You will need to hide the notification again by clicking on the “Hide notification permanently” link. Try the new plugin version 1.2.2.
    If the problem is still not resolved, let me know!

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Cannot Hide Webcraftic Pro Version message’ is closed to new replies.